
It’s time to pull together a variety of skills you’ve
learned in the previous lessons and put them to
work. Your assignment is to create the opening

for a show about surviving heart attacks. We’ll start
by creating a mock-up of a 3D world, testing the
camera move, then replacing each placeholder
with the final elements. 

We’re going to assume you already have some experience
using After Effects (or can refer back to earlier lessons as
needed), so our instructions will be a bit sparser than
normal. Our focus here will be on design considerations, 
as well as how to plan out a project – including recovering
when that plan doesn’t work.

Before You Begin (Any Job!)
Before you start any motion graphics job, it’s important to
learn the client’s parameters: what format your final render
should be delivered in, as well as their budget to shoot or
otherwise acquire visual elements. In this case, we’ve been
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Final Project
Creating a show opening, from draft to completion.

� Getting Started
The project file and sources are contained in the Lesson 
12-Final Project folder on this book’s disc; copy this folder 
to your hard drive. This project file contains numerous
intermediate comps for you to check your work against.

� In This Lesson
326 delivery specifications
327 music considerations; creating the main comp
328 spotting music
329 mocking up the 3D world; Label colors
330 3D view layouts
331 initial camera move; Separate Dimensions
334 placing the 3D background
335 3D Camera Tracker
336 time stretch; frame blending
337 typesetting the title
338 applying text animation presets
339 timing animation to music
340 using shapes to create a video frame
342 creating a reusable element
343 crafting an efficient composition hierarchy
344 replacing placeholders; ETLAT
345 filling out the background 
346 creating animated lines
348 using expressions to animate to music
350 enabling Motion Blur; rendering a proof
351 delivering a broadcast package
352 ideas for enhancing the final project

In this final project, you will follow a typical real-world workflow,
proceeding from a proof-of-concept mock-up (left) to the finished
piece (right). Videos courtesy Artbeats and iStockphoto.



told final delivery is to be a 1920¥1080 pixel high-definition video file, 20 to
30 seconds in duration, at 23.976 frames per second – the video equivalent
of the traditional film frame rate. (Since we don’t want to overtax your 
computer, we’re building this project at half that size – 960¥540 – and have
scaled down the source material accordingly.) Although it is to be delivered
with a 16:9 widescreen image aspect ratio, we have been told to “protect” 
for 4:3 center-cut, where a standard definition version is cropped out of the
middle of a scaled-down version of the final image. We’ve also been told the
budget is tight, so we’re going to use high-definition footage only for the
“hero” shot, and employ lower-cost standard definition video for additional
elements. We’ll also be creating elements from scratch.

The next task is to nail down the music. We like to use the soundtrack as 
a timing grid for our animation – so the sooner we can specify at least the
tempo of the music, the better. We researched typical heart rates and found
they fall in the range of 60 to 100 beats per minute (bpm), with 72 being
common for men. We then looked at our chart of “Magic Tempos” for 
animation (included in the Lesson 12-Final Project > 12-Bonus Content
folder) and found that for 23.976 video, a musical tempo of 71.93 bpm pro-
duces a nice, clean animation rate of 20 frames per beat (fpb). We instructed
the composer to use this tempo for the soundtrack, and he handed us back 
a piece of music just under 25 seconds in length – perfect. Now we’re ready
to start without fear of having to throw out and redo a lot of our work if 
we learned these details later. 
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Part 1: Outlining the Main Composition

� Previsualization Aids 

It’s not unusual to be asked to supply a

series of style frames before starting a

motion graphics projects. These are often

still images that show the look and feel 

of the overall design, including the type

choices and the color palette. The frames

could also show the progression from

start to finish, including notes on how

transitions might occur. We prefer to use

After Effects rather than Photoshop to

create these style frames, since we have

access to all the tools we’ll be using for the

real animation. By trying out various plug-

in settings, you can save research time

when the design is eventually approved.

You can also help the client better visual-

ize your ideas by creating mini-animations

to show how type or effects will animate

or transitions will occur. 

You might also be asked to supply an

animatic (an animated storyboard), which

is what you will be creating in Part 1 of

this lesson. These block out the major 

sections and transitions in a more complex

animation or commercial, and they test

the progression of scenes before live action

is shot. This helps avoid spending time ani-

mating or shooting a scene that later ends

up on the cutting room floor, or finding

out that a crucial part of the story is

missing. Animatics can be a series of stills

with captions, or simple 2D or 3D anima-

tions with voiceovers, depending on the

time constraints and budget of each job. 

Corporate video projects often include

a script. Go through the script with the

producer, highlighting the sections you

will need to create motion graphics for,

and coordinate with the video editor to

make sure all graphics are accounted for.

Before we go too far down the road creating elements, it is wise to first 
mock up a rough version of our composition, spot the music (Lesson 5), 
and test the timing of the 3D camera move (Lesson 8) to make sure our
general idea is going to work.

Creating the Main Comp

1 Open the project file Lesson_12.aep, set the Workspace to Standard, 
then Reset it. If you want to peek and get an idea of where you’re going,
open the Finished Movies folder, open the Final Comp.mov in the Footage
panel, and RAM Preview. (Remember that pressing the spacebar will initiate
a Standard preview without audio.)

2 Select the Comps folder in the Project panel; this is where you’ll keep the
compositions you create. Then choose Composition > New Composition.
Name it “ Final Comp” (we add a leading space so it will sort to the top of



the Comps folder); based on our client specs and music enter a Width of 960,
Height of 540, Square Pixels, Frame Rate of 23.976, Start Timecode of 0:00, and
Duration of at least 25:00. Set the Background Color to black, then click on the
Advanced tab and set the Renderer to Classic 3D (called Advanced 3D prior to
After Effects CS6). Click OK.

Spotting the Music

3 Back in the Project panel, twirl down Sources > music. Select Final Beat.wav
and type C/ on Mac (L/ on Windows) to add it to Final Comp.

4 With Final Beat.wav selected, type ll (two ls in quick succession) to
reveal its audio waveform. A series of tall, evenly spaced spikes are easy to see in
the waveform. Press . (the decimal key on the numeric keypad – MacBook users
may alternately press L.) to preview just the audio and note how the heart-
beats as well as drums correspond to these spikes.

5 Move to 00:05 where the stronger (taller) of the two beats in the first heart-
beat occurs. With Final Beat.wav selected, press X (asterisk on the numeric
keypad; MacBook Pro users may press L8) to place a Layer Marker. 

Now let’s see if the composer did what we asked: Press Sª twice 
to jump ahead 20 frames to 00:25. Lo and behold – there’s another beat there,
just as we planned! Press X to place another marker, and continue to do so
throughout the soundtrack. 

5–6 For the most part, tall spikes in the
waveform correspond to an audible beat
every 20 frames. Our final spotted
soundtrack contains markers for the main
beats as well as comments where the
music changes.
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2 Create your final composition based on
the client’s delivery specifications plus the
duration of the music. It’s not a bad idea to
make your final comp longer than you think
you’ll need; it’s easier to shorten a comp than
extend it after you’ve done a lot of work.

6 Now that you have the major beats marked out, go back and preview the
music again, listening for major events or sectional changes such as the start and
end of the main body of the music, as well as prominent details such as cymbal
rolls or the last piano note. Double-click these markers to open their Layer
Marker dialogs and enter short Comments to note these events. Then twirl up
the Final Beat.wav layer. Our version is in Intermediate Comps > 01_Spotted
Music; save your own project so you don’t lose your work.
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Mocking Up the 3D World
Our budget allows us to use a full-frame high-definition
footage for the final “hero” shot, but we have to use
smaller standard-definition footage for the other video
clips. Scaling up standard-def video to fill a high-def
frame can look ugly. A common design workaround is 
to place an assortment of smaller videos in 3D space,
perhaps adding a stylized frame to make them more
interesting.

We joke that working in 3D takes three times as long.
As tempting as it may be to create a visually beautiful
world right from the start, the prudent approach is to
first mock up your world and test your camera move to make sure 
your design works before spending too much time implementing it.

7 Let’s start with the hero. As mentioned earlier, we’re working at half size, 
so we need to create a stand-in layer that is at least 960¥540 pixels for the 
high-def hero. Then we need to leave space for its frame. As a
starting point, let’s leave roughly 25% of its height (an additional
140 pixels) all around for the frame.

Choose Layer > New > Solid, enter a Width of 1100 and Height
of 680, and set the color to yellow. Name it “Hero Shot” and click
OK. It will automatically be centered in the composition, which is
the planned final placement. Then in the Timeline panel, click on the color
swatch in the Label column at the far left and choose Yellow.

8 Our smaller videos are 320¥240 pixels (roughly half the square-pixel size of
standard def NTSC video). Again, we want to leave about another 25% of the
height (60 pixels) for the frame. Choose Layer > New > Solid and set Width to
380 and Height to 300. Set the color to red, name it “Extra 1” and click OK.
Then change its Label color to Red to match.

9 Duplicate Extra 1. With the duplicate selected, choose Layer > Solid Settings;
After Effects will automatically change its name to Extra 2. Change its color to
green, click OK, then change its Label color to Green. Repeat this twice more for
Extra 3 and 4, coloring them blue and orange respectively.

10 Next let’s arrange the layers horizontally. Type C- (L-) to scale
down the Comp panel to 25% Magnification, or until Hero Shot is less than a
third as wide as the Comp panel. Press the spacebar to temporarily engage the
Hand tool, and drag the visible portion of the comp to the right, leaving an
empty pasteboard to the left.
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� tip
The Magic Tempos
Specific music tempos correspond to
simple integer numbers of frames between
musical beats. A chart of these tempos at
various frame rates – plus the reasoning
behind them – is included on the book’s
DVD-ROM in Lesson 12-Final Project >
12-Bonus Content.

An effective way to use small standard
definition or even web videos in a high-
definition project is to arrange them in a
3D world, adding frames to make them
more interesting.

7 Set the Label color (where the cursor is
pointing) the same as your solid’s color. By
doing so, it will be easy to correspond what
you see in the Comp and Timeline panels.
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Drag the Extra layers to the left and arrange them in a pleasing pattern. 
Press p to reveal the Position of selected layers to numerically verify their
arrangement. We personally chose to spread the Extra layers 500 pixels apart 
in X and staggered ±170 pixels in Y compared with the centerline of Hero Shot;
you can align their top and bottom edges or make a freestyle arrangement. 
Just make sure Extra 4 does not overlap Hero Shot, as you need to see it 
unobstructed at the end.

11 Our mock-up has our video layers
arranged as a gallery wall, spaced evenly
in X and staggered in both Y and Z. 
Our version is in Intermediate Comps >
02_3D Mockup.

10 Arrange the Extra layers on the
pasteboard as a “gallery wall” of images for
the camera to pan across (right). If you want
to space them uniformly, use the Align
panel, or check their Position values (above).
(Note: Align works with 2D layers, but not
3D layers, so use this tool before you enable
the 3D Layer switches in Step 11.)
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11 Select all of the layers except
Final Beat.wav and enable their 
3D Layer switches. Set the View Layout
option to 4 Views – Bottom and 
verify the view ports are set to 
Active Camera, Top, Front, and Right.
Remember you can use the Camera
tools (page 215) to optimize these
views; the quickie solution is to select
each of the bottom view ports. Then
choose View > Look at All Layers.

Arrange layers Extra 1 through 4
in Z space to create multiplaning 
(explained on page 210) when the
camera pans by them. We chose to
stagger them ±150 pixels in Z 
compared with Hero Shot, but again
you have some freedom here. Leave
Hero Shot at its original Z Position;
this will make it easier to craft the
camera move in the next section.

1 3 hero
2 4
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Creating the Camera Move
We communicated with the musician that our idea was to have a camera move
that slowly pans past a bunch of videos, settling on the hero shot and title. With
that information, plus the title of the show, he crafted a piece where the music
starts mysteriously with just a heartbeat; a cymbal roll leads from this into the
piano melody. The melody then ends with another cymbal roll leading into a
large crash, returning to the original heartbeat. 

The animation can now be synced in time with these
musical accents: We’ll start looking at just an abstracted
background (which we’ll build later), pulling back during
the first cymbal roll to reveal the video screens when the
melody starts. We’ll pan past the videos during the melody
and zoom in during the second cymbal roll to end on our
hero video – and show title – at the crash. The remaining
duration will give the viewer time to read the main title
(and for the editor to fade to black or crossfade into the 
first scene of the show).

12 Create a Layer > New > Camera. For simple pans, pull-
backs, and push-ins, a one-node camera (with no Point of
Interest) is easier to use. Select this option from the Type
popup, then chose a Preset of 35mm (a “short” lens) to exaggerate the 
perspective distortion during the moves. Disable Depth of Field and click OK.
When you create a new camera, it defaults to showing any layer that has its 
Z value at 0 at its original size, which is perfect for framing Hero Shot.
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13 Enable Separate Dimensions (left) to make it easier to keyframe each component of the
camera move. Then enable keyframing for X, Y, and Z Position (right). Note how the X and Y
Position of the newly created camera match the default position of Hero Shot – that was by
plan, not by accident.

13 Quite often, a good strategy for
creating an animation move is to
start where you’ll end – in this case,
centered on Hero Shot at the time of
the crash. Locate the current time
indicator (“CTI” for short) to 16:21
where you’ve marked the crash in the
soundtrack. With Camera 1 selected,
press p to reveal its Position. Right-
click on the word Position and
choose Separate Dimensions, then
enable keyframing for the X, Y, and Z
Position parameters. This will make it
easier to keyframe the pull out and
push in (Z Position) separately from
the pan (X Position).

12 Create a one-node camera with a short
lens length. This will make it easier to control
for simple panning moves and exaggerate
the perspective distortion in 3D so we get
more impact from relatively simple moves.
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14 We’ve chosen to start our move centered between Extra 1 and Extra 3
and above Extra 2 so when we pull back we’ll see three of our video frames. 
(You may have a different arrangement in space than us; modify our instructions
as needed to match your world.)

• Move to 01:01 – the heartbeat where the cymbal roll starts. In our arrange-
ment, Extra 2 (green) is centered in X between the red and blue solids, so take
its X Position value and enter it for Camera 1’s X Position. 

• Next take the Y Position of Extra 1 and 3 and enter it for Camera 1’s Y Position. 

• Finally, scrub Camera 1’s Z Position to zoom into the scene until the Extra
layers disappear off the edges of the Active Camera view. In the process,
keyframes for all three values will be set.

15 Press k until the CTI (current time indicator) jumps to the marker where
the piano melody begins (03:13); if you go too far, press j to jump back in time.

• To pan across the center of the screens, set Camera 1’s Y Position back to 270. 

• With the Active Camera view selected press F (apostrophe) to toggle on the
Title/Action Safe Grids and scrub Camera 1’s Z Position until all the visible Extra
screens sit inside at least the upper and lower Action Safe grid. Remembering
that the client asked us to protect for the inner 4:3 center-cut area, we backed up
in Z even farther to –1800 to make sure all viewers saw multiple screens at once.
Don’t touch the X Position; we want to continue a smooth horizontal pan.

16 We noticed there are three beat markers between the two “pull back”
keyframes we just set. To keep the same pacing for the final push in, move to
14:09 (three beats before the ending crash), click once on Camera 1’s earlier 
Z Position keyframe at 3:13 and copy it, then paste it to the current time.

17 Camera 1’s Z Position should still be selected. Press S and click the
words X Position in the Timeline panel to select all of the Position keyframes,
and press ( to apply Animation > Keyframe Assistant > Easy Ease to them. 
Press 0 on the numeric keypad (MacBook users may press L plus the 
normal 0 key) to RAM Preview your animation. 

14 We’ve keyframed our beginning and
ending poses. Next is creating the camera
move in-between.
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� tip
Don’t Blow Up
To make sure you’re not scaling a layer
over 100% from the camera’s perspective,
duplicate the suspect layer, disable its 
3D Layer switch, drag it into view, and
return its Scale value to 100%. If the 3D
version is the same size or smaller, you’re
not blowing up pixels, meaning it will
render at full quality.

� factoid
Which Renderer?
In this project, we anticipate using
blending modes and effects to construct 
a more interesting background. As modes
and effects are incompatible with the 
Ray-traced 3D Renderer in After Effects
CS6 (you might be using an earlier version
anyway), we are using the Classic 3D
Renderer instead. 



Feel free to tweak the position 
of the layers and camera until you
have a move you like. In our case,
we decided we wanted the Extra
layers to overlap when we panned
past them; we also thought the
Extra layers were looking a bit
small compared with the Hero
Shot. To solve both problems, we
scaled up the Extra layers by 165%,
as they were still far enough back 
in 3D space that we wouldn’t be
blowing up their pixels. This in
turn required us to push in further
for our initial keyframe (at 01:01) 
to make sure the Extra layers didn’t
encroach on our view.

Marking the Camera’s Timing
Our version to this point is in Intermediate Comps > 03_Camera Move; note
the addition of Composition Markers (pages 145–146). Once we settled on the
camera move, we thought it would be useful to note when the various video
layers come into and go out of view. This will help us if we want to time an
action in these videos to when they are on screen, or if the clips aren’t long
enough to last the entire composition. To add these to your own composition:

18 Locate the CTI to the first camera keyframe at 01:01 when the video layers
are all out of view. Then press ª to step forward a frame at a time until
you reach the first frame when the Extra layers come into view. Press @ to dese-
lect all layers. Hold O (A) and press X on the numeric keypad to open the
Composition Marker dialog. Enter a brief Comment about which layers appear
and click OK. Repeat this procedure as each new layer enters the camera’s view.

19 Keep stepping forward until the first layer disappears from view. Press
• to back up one frame, and press OX (AX) to create a new Comp
Marker. Enter the name of the layer that is about to leave and click OK. Repeat
this for each of the remaining Extra layers as they leave the camera’s view.

18–19 You can add helpful Comments
to both Composition and Layer Markers
(above). Create Comp Markers (below)
noting when each layer enters and leaves
the camera’s view. This will come in handy
later when you need to trim or otherwise
edit the timing of these layers.
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17 In our final camera move, the Extra
layers overlap after being scaled up 165%.
We made sure we pulled back enough in Z
to fit multiple screens inside the safe areas.



Now that we have our 3D world and camera move mocked up, we can start to
insert the real layers. We’ll start by placing the background (because it’s quick
and easy, and sometimes it’s nice to feel like you’re making progress), then
focusing on the real hero shot plus our show’s title. Before diving in, save your
project, then use File > Increment and Save to start a new version number. 

2 Push the background layer far away in Z, then scale it up 
and position it so that its edges (indicated in both figures by the
red arrows) remain out of view at the extremes of the camera’s
movement. If you tweak the camera move later, remember to
come back and recheck this to make sure no gaps reappear.
Background courtesy Artbeats/Liquid Abstracts.
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Part 2: Background and Hero Layers
� factoid
Shoot Your Own
Yes, the client brief was we had to save
money on stock footage – but we created
this background ourselves! Look inside
Lesson 12-Final Project > 12-Bonus
Content for an article we wrote for 
Artbeats on creating backgrounds like these.

If you’re just joining us, our version to this point is
Intermediate Comps > 03_Camera Move.

Placing the Background

1 Back in the Project panel, twirl down Sources >
movies. Select Liquid Abstract.mov and drag into 
Final Comp, placing it below the Extra and Hero layers.

You can often get away with a soft, full-frame 2D 
layer as a background for a 3D world. But it doesn’t 
take much work to place it in 3D, where you can enjoy
the benefits of multiplaning.

2 Enable the 3D Layer switch for Liquid Abstract.mov
and press p to reveal its Position. Push it far back in Z
so it appears to be far away and doesn’t move as much
as the foreground layers. We used a value of Z = 5000.

Then press Ss to reveal its Scale, and scrub it
larger until it fills the frame (add S to scrub in 
larger increments). Check the second and third camera
keyframes – where it has the widest view of your world –
to make sure the background layer remains in view for
the entire composition. To minimize how much you
have to scale up this layer, try sliding it in X so that 
its left edge is just out of view at the second keyframe,
and its right edge is just out of view at the third camera
keyframe. 

With our camera move, we found that a Scale value 
of just over 900% was enough (as seen in Intermediate
Comps > 04_Background). This means the layer will
still be viewed at more than 100% of its original 2D size,
but since it’s intended to be an out-of-focus background
anyway, we’re less concerned than we would be if it was
a foreground layer.

03:13

14:09



Tracking the Hero Camera
Next, we want to track the original camera movement in our hero footage so our
title will appear to move as if it existed in the original scene. To do this, we’re
going to use the 3D Camera Tracker introduced in After Effects CS6 (Lesson 9).
Our hero footage is not an ideal shot to track – there are too many people moving
in the scene, and too few stationary features to track – but as we’re not perform-
ing a critical composite, just capturing the spirit of the move is good enough. 

3 Select the Comps folder in the Project panel and create a Composition > 
New Composition. Set its size to 960¥540, Square Pixels, Frame Rate to 23.976,
and Duration to 25:00 to match Final
Comp. Enter the name “Hero + Title”
and click OK. You can set the View
Layout back to 1 View for now.

4 Twirl open the Sources > movies
folder and drag Surgery.mov into 
your new comp. With Surgery.mov
still selected, if you’re using CS6,
choose Animation > Track Camera.
You will see a blue Analyzing banner
followed by an orange Solving banner.

5 We want to place the title in front
of the foreground surgeon. Drag the
CTI through the duration of the clip,
looking for a Track Point that appears
stuck to his body that is preferably
near the center of the frame where 
our title will go. Select this point, 
then right-click it and choose the
option Create Null and Camera. 
An animated 3D Tracker Camera
layer plus a stationary Track Null 1
layer will be added to the timeline.

If you have After Effects CS5.5 or
earlier, you can copy our 3D Camera Tracker and Track Null 1 layers 
from Intermediate Comps > 05_Tracked Hero and paste them into your 
composition. Or, you can try to approximate the move yourself by creating a
Layer > New > Camera and keyframing it. Note the 3D Camera Tracker solved
this scene as having a small Angle of View; use a value of 5 to 10° to match 
the perspective in the shot. 

5 Select a stable Track Point on the
foreground surgeon, right-click, and create 
a null object as well as a camera (above).
These will be added to the timeline (below).
(CS5 and 5.5 users can copy our null and
camera layers.) Footage courtesy iStock -
photo, evandrorigon, image #17590052.

FINAL PROJECT — Lesson 12
335

Excerpt from After Effects Apprentice, 3rd Edition.  Copyright © 2013 Trish and Chris Meyer. All Rights Reserved. Focal Press, ISBN 978-0-240-81736-1


