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For a full list of CS5 changes, see Adobe Community Help >  
After Effects CS5 > Using After Effects CS5 > What’s New 

 

General changes for all lessons: 

 In After Effects CS5, double-clicking a footage item, such as a QuickTime 
movie, in the Project panel will now open the movie in the Footage panel. 
To open it in QT Player (or whichever media player is assigned to open 
that file type in your current operating system), press Option on Mac (Alt 
on Windows) when you double-click.  

 As of AE CS5, you now change the background color at the bottom of the 
Composition > Composition Settings dialog, instead of using the 
Composition menu.  

 The Color Picker and many other dialogs in CS5 now have a Preview 
option so you can see the result of your changes before you close the 
dialog. Dialog boxes for which the Preview option has been added include 
Interpret Footage, Composition Settings, Camera Settings, Solid Settings, 
Light Settings, 3D Rotation, and all transform property dialog boxes. 

 errata: The correct phone number for Focal Press Customer Service is 
1(800) 545-2522, not -2422. 

 



PRE-ROLL 
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4 Importing Footage: 
The “Import Folder” button has been removed from the Open File dialog. 
To import a folder, simply select it and click the Open button. 

4 Importing Footage: The terminology (but not the function) of importing a 
layered PSD or Illustrator file has changed: 
Import As: Composition – Cropped Layers 
has been renamed to: 
Import As: Composition – Retain Layer Sizes 

7 New Alpha Boundary and Alpha Overlay view modes have been added 
along the lower left edge of the Layer panel. 

9 Effect Controls panel (ECP): 
The Animation Presets popup is shown by default in CS4, but has been 
hidden in CS5. To enable, select “Show Animation Presets” from the ECP 
Options menu. 

12 The layout for Adobe Bridge varies with every release, but the basic 
functionality for After Effects hasn’t changed. 

 



LESSON 1 – BASIC ANIMATION 
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20 Step 12: In CS5, you now change the background color at the bottom of 
the Composition > Composition Settings dialog. Updates are interactive. 

21 errata: Step 15: In earlier versions, the current time indicator (CTI) head 
was blue; the CTI head is yellow in CS4 and CS5. Oops! 

21 Step 16: If you are using a Mac laptop, alternative shortcuts have been 
added in CS5 for operations that relied on having a numeric keypad. For 
instance, you can press Control+0 to RAM Preview. Check out the After 
Effects CS5 What’s New in the Adobe Community Help for more details. 

24 The size of the vertex point and direction handles on a motion path 
(which also affects masks and shape layers) can be increased in CS5. 
See: Preferences > General > Path Point Size 

30 Step 37: Alternate method in CS5 for snapping to edge of comp:  
The Window > Align panel has been improved. You can now Align Layers 
to > Composition and then pick from top, bottom, sides, etc.  

33 errata: Idea Corner, first bullet, line 3: should read “...sliding the 
snowstorm layer...” 

34-35 Importing Footage: The terminology (but not the function) of importing a 
layered PSD or Illustrator file has changed: 
Import As: Composition – Cropped Layers 
has been renamed to: 
Import As: Composition – Retain Layer Sizes 

35 When importing with Live Photoshop 3D enabled, if using Photoshop CS5 
Extended with AE CS5, then this also includes Adobe Repoussé support. 

 

Notes: New in CS5: Auto-keyframe button (looks like a large stopwatch) has 
been added to the Timeline panel. When enabled, it will be red. Enabling 
the mode will automatically turn on the animation stopwatch for any 
property you edit for any layer in any composition, potentially resulting in 
unintended keyframes. For this reason, we suggest you don’t enable it (in 
fact, feel free to just ignore this...!)  



LESSON 2 – ADVANCED ANIMATION 

The steps should all work the same in CS5 as in CS4. Variations are noted 
below: 
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37 Work Area: When you click the work area bar in the Timeline panel, the 

Info panel shows the beginning and end times of the work area, as well as 
its duration. 

38 errata: Step 1, line 8: 
On Mac, press Command – on Windows, this should be Control (not Alt). 

42–51 The Graph Editor: When you hover your cursor over a vertex (keyframe) 
in the Graph Editor, a tooltip now displays the name of the layer, property 
name, time, and value without having to move the keyframe first. 

58 errata: Step 1, line 4: 
The goal is to have the word slam into position by 01;00 rather than 
02;00. The following steps are correct. 

 



LESSON 3 – LAYER CONTROL 

The steps should all work the same in CS5 as in CS4. Note minor changes: 
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72 Blending Modes: CS5 added two new blending modes: Subtract and 
Divide. See Online Help (Blending Mode reference section) for details. 

77 Step 2: In CS5, the Show Animation Presets option in the Effect Controls 
panel is now off by default.  

82 Step 3: (minor bug in CS5) If the twirly arrow to reveal Layer Styles is 
missing, double-click the words “Layer Styles”.  

 

 



LESSON 4 – CREATING TRANSPARENCY 

The steps should all work the same in CS5 as in CS4. Note minor updates: 
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96 Mask Paths: The size of the vertex point and direction handles on a mask 
(which also affects motion paths and shape layers) can be increased in 
CS5. See: Preferences > General > Path Point Size 

 

General: 

 New in CS5: When you change the mask path color (by right+clicking on 
the color swatch), this new color is used as the default mask path color 
for all new masks; it even persists after rebooting the program.  

 



LESSON 5 – TYPE AND MUSIC 

The steps should all work the same in CS5 as in CS4. CS5 enhancements 
include: 
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116 New in CS5: To create a nonbreaking space, select the space between 
words you wish to keep together and then select the No Break command 
from the Character panel’s Option menu. 

116 2nd bullet item: New in CS5, double-clicking the Type tool creates a new 
text layer; the cursor will be centered in the Comp panel. This gives the 
same result as selecting Layer > New > Text Layer. 

124-125 “One Word at a Time” tutorial: 
New in CS5: When you are rotating and scaling individual characters and 
words (as in this tutorial), the anchor points are now shown in the 
Composition panel; this can help you better predict how a text animation 
will behave. The anchor point – it looks like a small “x” – is visible only 
when certain properties (Anchor Point, Position, Scale, Rotation) are 
selected inside the Animator. Note that simply selecting the layer, or the 
Animator, is not enough – you need to click on the name of the property 
to view the anchor points. Note: More Options > Grouping Alignment is 
another way to change the global anchor point for all animators. 

127 Text on a Curve:  
New in CS5: The Path Options section in the Timeline now sports a 
visibility option (eyeball) so you can toggle on and off the text on a curve 
option. (In CS4, the only way to toggle off the text on a curve is to set 
the Path popup to None, but if you reset it to Mask 1 again any previously 
set Path Option settings are lost.) 

128-131  Per-Character 3D: See note above for pgs 124-125. 

 Note:Although not specifically covered in this section, Per-Character 3D has the ability to 

auto-orient text towards a 3D camera. To do this, select Layer > Transform > Auto-Orient 

and select Orient Towards Camera in the Auto-Orientation dialog. This will swivel the 

entire layer to look at the active camera. In CS5, a new option has been added to the 

Auto-Orientation dialog: When you select Orient Towards Camera, you can also toggle on 

an option to Orient Each Character Independently as well which will swivel it around its 

anchor point towards the active camera. 

136 Audio Preview: In CS5, the audio preview duration now defaults to a more 
usable 30 seconds (previous 8). This is set in Preferences > Previews. 

136-7 If you are using a Mac laptop, new keyboard shortcuts have been added 
to compensate for the lack of a numeric keypad: Control+. (period) will 
start an audio-only preview; Control+8 will place a layer marker. 



LESSON 6 – PARENTING AND NESTING 

The steps should all work the same in CS5 as in CS4. Variations and new 
features are noted below: 
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149 The Align panel in CS5 has been enhanced. You can now also align layers 
to the center and sides of a Composition. In CS4, you can only align 
layers to other layers.  

150 Tip: “Opening Precomps”: 
This Tip is still correct: Double-clicking a precomp’s layer in the main 
comp opens the precomp. Pressing Option on Mac (Alt on Windows) and 
double-clicking opens the Layer panel.  
However, in CS5, if you double-click a precomp layer when either the 
Paint or Roto Brush tool is selected, the Layer panel will open. This is 
because After Effects assumes you want to use the paint or roto tools and 
these tools only work in the Layer panel. If you instead want to open the 
nested composition itself when one of these tools is active, press Option 
(Alt) when you double-click on the precomp layer. 

157 “Edit This, Look at That” (ETLAT) Sidebar: 
This example shows ETLAT mode in use with the Effect Controls panel. In 
CS5, ETLAT mode has been enhanced to also work with compositions. You 
can now open all compositions that you might wish to view or edit, then 
click the lock switch in the Composition tab for the top comp (in this 
tutorial, that is the Locations_final comp). Click the tab in the Timeline 
panel to bring a precomp forward for editing – the top comp remains 
visible in the Comp panel so you can see how your changes affect the top 
comp. (This mode is covered in detail in Creating Motion Graphics 5th 
edition, pages 333–4.)  

 Of course, you can continue to create two Comp viewers for even more 
flexibility by using the split view shortcut: Select the Composition panel 
and press Command+Option+Shift+N on Mac (Ctrl+Alt+Shift+N on 
Windows). Then lock the top comp’s panel, and then load the precomp 
into the second comp panel. As you edit the precomp, you’ll be able to 
see both the precomp and the top comp. (Try this approach with Step 13 
on page 156.)  

 



LESSON 7 – EXPRESSIONS AND TIME GAMES 

The steps should all work the same in CS5 as in CS4. Variations are noted 
below: 
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189 Step 8: The Graph Editor: When you hover your cursor over a vertex 
(keyframe) in the Graph Editor, a tooltip now displays the name of the 
layer, property name, time, and value without having to move the 
keyframe first. 

 



LESSON 8 – 3D SPACE 

The steps should all work the same in CS5 as in CS4. Variations below: 
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General: When a composition contains a 3D layer, camera, or light, the 
Composition panel now displays a label (Top, Left, and so on) in the top-
left corner of each view. This is particularly handy when viewing multiple 
views such as 2-up, 4-up, etc. In After Effects Apprentice, we manually 
added this labels (such as in the illustrations on page 199) to make this 
more clear. To hide these labels in CS5, deselect Show 3D Labels from 
the Composition panel’s Options menu. 

200 Step 2: The Camera Settings dialog now sports a Type popup, where you 
choose from a One-Node Camera (no Point of Interest) or Two-Node 
Camera (with Point of Interest). The Type popup in Camera Settings will 
default to the previously selected choice, persisting between sessions.  

 For our tutorial, select the Two-Node Camera (the default in CS4). 

 Note: In CS4, you could only set the camera “type” in the Layer > 
Transform > Auto-Orient dialog, which was a little disconnected! 
Specifically: 
• for a Two-Node Camera, select “Orient Towards Point of Interest” 
• for a One-Node Camera, select “Off” (this is covered on page 204).  

201 Unified Camera Tool enhancements:  
Dragging in the Composition panel with the Unified Camera tool selected 
temporarily activates the Orbit Camera tool. New in CS5: Adding the Shift 
key as you drag will constrain rotation to one axis. 

 Dragging in the Composition panel with the Unified Camera tool selected 
and the right mouse button pressed temporarily activates the Track Z 
Camera tool and modifies the Position of the Camera only. If you also 
press the Command key on Mac (Ctrl key on Windows), you will modify 
both Position and Point of Interest. 

204 Step 3: As noted above, instead of selecting Off in the Auto-Orientation 
dialog, in CS5 you can also double-click the Camera layer to open the 
Camera Settings dialog, then set the Type popup to “One-Node Camera”. 
The result is the same: The Point of Interest will be disabled, and the 
camera faces wherever it is pointing.  

215 Step 8: Import File dialog: the Import As popup: Composition – Cropped 
Layers has been renamed to: Composition – Retain Layer Sizes 

216 Step 2: Import File dialog: the Import As popup: Composition – Cropped 
Layers has been renamed to: Composition – Retain Layer Sizes 



LESSON 9 – TRACK AND KEY 

The steps should all work the same in CS5 as in CS4. Variations are noted 
below: 
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229 Tip: “Mocha for After Effects” 
CS5 now comes bundled with mocha for After Effects CS5 v2 plus mocha 
shape. We cover these advanced features in Creating Motion Graphics 5th 
Edition for CS5. 

239-240 When refining the edge of a key, you could also use the new Refine Matte 
effect in CS5 (Effect > Matte > Refine Matte) to perform edge 
enhancements. See the Online Help file for details.  

240 Sidebar: “Creating a Garbage Matte” 
Composite Toolkit is no longer available from dvGarage. We now 
recommend The Green Screen Handbook by Jeff Foster. Likewise, the 
dvMatte plug-in no longer available for After Effects. 



LESSON 10 – PAINT AND PUPPET 

The steps should all work as expected. Changes in CS5 are noted below: 
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253 Idea Corner: “Wiggle Stroke” 
The Vector Paint effect (VP) was originally created by Cycore and then 
purchased by Adobe. VP has one big advantage over Paint – the individual 
strokes can “wiggle.”  

 Unfortunately, the Vector Paint effect has been made obsolete in CS5. 
“Obsolete” means you can no longer apply it to a new layer (using Effect 
> Paint > Vector Paint). However, if it is already applied in a project 
created in CS4 or earlier, it should continue to render correctly in CS5, 
and you can change the popup values in the Effect Controls panel – you 
just can’t paint new strokes or edit existing strokes.  

 Since we’d already applied it to the Vector Paint*starter comp, you can 
continue with the tutorial if you wish. Just don’t get too excited...and if 
you like this effect, you might want to keep an old copy of CS4 around. 

261 In the first figure, the Animation Presets popup is visible in the Effect 
Controls panel. In CS5, the default is to hide this popup. To reveal it, 
select Show Animation Presets from the Effect Controls panel Options 
menu.  

 

Note 1: In CS4, the Paint effect could be applied from Effect > Paint, and the Puppet Tool could be 

applied from the Effect > Distort menu. In CS5, these entries have been removed from the 

Effect menu (as well as the Effects & Presets panel) since you rarely need to apply these 

effects directly. As soon as you use the Paint or Puppet tools on a layer, these 

corresponding effects are added to the selected layer. They can be resorted in the Effect 

Controls panel or the Timeline so they appear before and after other effects. 

Note 2: This following change in behavior is applicable only if you are painting on a nested comp 

layer (a precomp). In CS5, if you double-click a precomp layer when the Brush, Clone 

Stamp, or Erase tool is selected, the Layer panel will open. This is because After Effects 

assumes you want to use the paint tools and these only work in the Layer panel. If you 

instead want to open the nested composition itself when one of these tools is active, press 

Option (Alt) when you double-click on the precomp layer. 

 



LESSON 11 – SHAPE LAYERS 

The steps should all work the same in CS5 as in CS4. Variations are noted 
below: 
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263 Step 3: The size of the vertex point and direction handles on a shape 
layer (which also affects masks and motion paths) can be increased in 
CS5. See: Preferences > General > Path Point Size. 

 



LESSON 12 – FINAL PROJECT 

The steps should all work the same in CS5 as in CS4. Variations are noted 
below: 

page# /section 

 In general, remember that the Background Color has been moved to the 
Composition > Composition Settings dialog in CS5.  

286 errata Sidebar: “Illustrator Crop Area”:  
The following information replaces paragraph 2 in this sidebar:  

 The way that “document size” is handled for Illustrator files has changed 
considerably in recent versions. In Illustrator CS3 and earlier, you could 
create a box and then select Object > Crop Area > Make to set the 
bounding box. This option was removed in Illustrator CS4 and later. 

 Illustrator CS4 introduced the concept of Artboards to represent regions 
that can contain artwork. While Illustrator can create multiple artboards 
per document, After Effects will use Artboard 01 (the default when you 
create a new file) as the Composition size when you Import As > 
Composition. To edit the dimensions in Illustrator, double-click the 
Artboard tool to open the Artboard Options. Illustrator also includes a set 
of film and video document profiles. (Note the “Video Ruler Pixel Aspect 
Ratio” option; we recommend you set it to “1”.) 

 An advantage of using these presets in Illustrator CS5 is that if you create 
a new Illustrator file using one of the Video and Film presets, in addition 
to creating Artboard 01 at the appropriate size, it also creates a second 
artboard that is much larger (14,400x14,400 to be exact). Provided you 
import your file into After Effects as a Composition (and you have at least 
two layers), any imagery that falls outside Artboard 01 isn’t cropped off or 
lost – it will reside outside the composition frame, ready to be animated 
onto the stage. If the file was created without using a CS5 preset, create 
a second artboard at 14,400x14,400 – this magic size will trigger After 
Effects to behave the same way. 

287 Step 12: When we say we created the file’s “bounding box” at 600x600, 
this is technically correct as it was originally created in Illustrator CS3! In 
CS4/5, it’s more correct to say that the “artboard 01” in Illustrator is 
600x600, and that is what defines the size of the comp in After Effects.  

298 Steps 50-51: The default Center Cut Safe Areas were incorrect in After 
Effects CS4; they have been corrected in CS5. You might want to nudge 
elements a little closer to the center of the frame to make sure they won't 
be cut off if broadcast and viewed on a non-widescreen television. 



298 Step 53: When you select multiple views, a nice enhancement in CS5 is 
that the Composition panel now displays a label (Top, Left, and so on) in 
the top-left corner of each view.  

300 Step 57, last bullet item: In CS5, you can also double-click the Type tool 
to create a new text layer in the middle of the comp. 

 

 

 

APPENDIX – RENDERING 

Note: In C5, in the Output Module Settings dialog box, the Output Module 
Templates dialog box, and the Output Module section of the Render 
Queue panel, Stretch has been renamed to “Resize”. Also, if you choose a 
codec that is not compatible with the composition size you are rendering, 
a Settings Mismatch warning will appear along the bottom of the Output 
Module dialog. 

311 The FLV and F4V Options dialog have been streamlined considerably in 
CS5.  
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