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ProAnimator by Zaxwerks and Video Copilot’s Element 3D. Also, C4D Lite is 
indeed a feature-reduced version of the full program. If you already have a full 
version of CINEMA 4D or another full 3D program, in most cases you’re better 
off using it instead of C4D Lite. But if you need more robust 3D than After 
Effects itself provides, and you don’t have the budget for any of these other  
solutions, C4D Lite can be very useful.

This lesson assumes you have no prior experience with a full 3D application, 
but are somewhat comfortable with After Effects’ own 3D implementation (if 
not, go back and work through Lesson 8). Learning modeling and 3D animation 
is the subject of a book in itself; we’ll be only touching on these lightly. But you 
will learn enough to be dangerous, including creating a videowall, animating 
text or a flying logo, and integrating an already built 3D model into an existing 
video scene. Although these are separate tasks, we urge you to go through all of 
them in order, as you will pick up progressively more tips about using C4D Lite 
with After Effects in each one. But first, we’re going to start with the setup tasks 
that are common to any project that uses After Effects and C4D. d	tip

Using the Full Version of C4D
If you own a full version of CINEMA 4D, 
you can tell CINEWARE to connect to that 
instead of C4D Lite. With CINEWARE applied 
to a layer, click on Options along the top of 
its effect controls. A dialog will open where 
you can relink which version is used for 
editing, as well as for rendering. 

In this lesson, you will learn how to build 
a videowall (A), animate 3D text (B), and 
integrate a 3D model into existing footage 
(C). A movie of each finished exercise can  
be found in the 12_Finished Movies folder.

Native After Effects 3D layers have many uses, 
but many limitations as well. Fortunately, 
After Effects CC comes bundled with a  

full 3D application – MAXON CINEMA 4D Lite  
(C4D Lite for short) – and a pipeline to integrate  
its output directly into the After Effects timeline.

That pipeline runs through the CINEWARE effect. Inside 
an After Effects composition you choose Layer > New > 
MAXON CINEMA 4D File, which creates a 2D layer with 
CINEWARE applied. This action also opens a corresponding 
blank project in C4D Lite. You can build 3D objects from 
scratch in C4D, or “merge” existing projects into your new 
project file. As you step through the After Effects timeline, 
CINEWARE requests a frame from the C4D Lite rendering 
engine and presents the results inside this After Effects layer. 
If you need to reopen the underlying C4D project file later, 
you just select the layer with CINEWARE applied and go 
Edit > Edit Original. CINEWARE also offers a number of 
useful options, including deciding which layers you’ve 
grouped in the C4D project or portions of the 3D render 
you want to see, whether to use the C4D or After Effects 3D 
camera, and the ability to extract camera and light data from 
the C4D file and re-create it inside After Effects.

As nice as this system is, it does have its limitations.  
One, 3D renders are often much slower than 2D, meaning 
you will find it slower to move through the After Effects 
timeline. Two, because CINEWARE is rendering the C4D 
scene all by itself, its results cannot currently intermingle 
with After Effects’ 3D layers; in other words, there are no 
intersections or automatic shadows between those worlds. 
This is the way essentially all “3D” plug-ins in After Effects 
work – including popular choices 3D Invigorator and 
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Integrating a 3D application into the After Effects timeline using CINEWARE.

	 d	 Getting Started
Make sure you have downloaded the file archive for  
Lesson 12 (as discussed in How to Use This Book) and 
decompressed it. It contains the project file and sources  
you need to execute this lesson. 

 D Additional C4D Reference
There are numerous books available from which to learn more about CINEMA 4D  

and C4D Lite, including:

•	 After Effects and CINEMA 4D Lite by Chris Jackson: Currently the only book 

dedicated to C4D Lite; includes its limitations compared to the full version of  

CINEMA 4D. It’s the perfect next step after reading this lesson.

•	 CINEMA 4D Apprentice by Kent McQuilkin: Another book in the Apprentice series, 

with in-depth information organized by topics, such as Lighting and Motion Graphics. 

Written for the full version of CINEMA 4D.

•	 CINEMA 4D: The Artist’s Project Sourcebook by Anne Powers and Kent McQuilkin: 

Also dedicated to the full version of CINEMA 4D, with numerous small projects.

Cinema 4D Lite 

	 d	 In This Lesson
	 362	 CINEMA 4D user interface
	 363	 Project and Render Settings
	 364	 frame rate issues
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	 367	 Extrude object
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The CINEMA 4D interface (version R16) is divided into major sections, outlined here. 
Throughout this lesson, we assume you are using the Startup or Standard Layout  
(selected in the upper right corner). The icons we use in this lesson are called out below.
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Project Setup
There are a few steps you need to perform every time you 
use C4D Lite and CINEWARE in an After Effects project. 
We’ll detail those steps here and then just quickly refer to 
them in the remaining exercises.

1	 Open Lesson_12.aep. Both the Lite and full versions  
of CINEMA 4D expect After Effects to be working in a  
very specific color space, so that color and compositing 
operations react the same in both programs. Open File > 
Project Settings, and verify the following changes in the 
Color Settings section:

•	 Set Working Space to sRGB IEC61966-2.1; the default  
for this is None.

•	 Enable Linearize Working Space; it defaults to Off.

•	 Optionally set Depth to 16 bits per channel (bpc).  
This will reduce color banding in your renders, with the 
trade-off of slower renders. You can work in the default 
8-bit mode for speed, then enable 16-bit mode in the 
Render Queue > Render Settings dialog.

You only need to do the above once per project file.  
Be warned that these settings will apply to all compositions 
inside that project, so we recommend you maintain a separate project file  
if you need to process other comps with a normal workflow. We have  
already performed this step for you in Lesson_12.aep; it’s good to always 
check when you receive a project from someone else. When you start a  
new After Effects project that will include C4D layers, you will need to 
perform this setup again.

2	 In the Project panel, double-click 01-Project Setup*starter to open it. 
Open Composition > Composition Settings to note its frame size (960×540 
pixels) and frame rate (29.97 frames per second); click OK when done. Go 
to the end of the comp and note the frame number count under the time 
display in the upper left corner of the Timeline panel – C4D thinks in terms 
of frames, not SMPTE timecode. Then return the current time indicator to 
the start of the comp.

3	 Choose Layer > New > MAXON CINEMA 4D File. A file dialog will open; 
name the file based on the content you’re about to create (let’s say Test.c4d) 
and save it next to your After Effects project or where you’re keeping its 
sources. Click Save, and C4D Lite will open.

D First Launch
The first time you launch CINEMA 4D Lite, you will see a 

Registration screen. Do register, as it activates additional 

tools that you need to complete this lesson. 

You may also see an Updates screen; if you don’t,  

to access it choose Help > Check for Updates from the  

Main menu along the top. Update to the latest version of  

CINEMA 4D. Also click on the Optional tab and download 

the Help Documentation/Language Pack (and, if available, 

the QuickStart) for your language. After you do so, you can  

right-click on virtually any tool or parameter in C4D Lite  

and be taken directly to the Help section on that subject. 

2	 The number in small type underneath 
|the main time display for the Timeline panel 
in After Effects is the frame count; this is 
|how C4D measures time. If you prefer  
to always count in frames, C on Mac  
(L on Windows) click on the value to 
switch the time display (as covered on  
page 68 in Lesson 2). 

1	 CINEMA 4D defaults to sRGB working 
space and linear color blending; duplicate 
this in After Effects’ Project Settings.

The CINEMA 4D interface (version R17).  
Note the new icon for the Spline tool.
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8	 To compensate for CINEMA 4D’s lack 
of support for noninteger frame rates, you 
need to conform the frame rate of your .c4d 
footage items to the correct fractional frame 
rate in the Interpret Footage dialog. 

7	 Retrim the length of the C4D layer to 
match the comp’s duration.
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7	 You will notice that the new layer in your comp for the C4D file has been 
pretrimmed to 3 seconds long, which is the default file duration in C4D Lite. 
Retrim its end to match the end of your composition.

8	 This step only applies if your comp has a fractional frame rate such as 
23.976, 29.97, or 59.94 fps. To compensate for CINEMA 4D supporting 
only integer frame rates, do the following:

•	 Right-click on the CINEWARE layer (the one that ends in “.c4d,” such 
as setup.c4d) and choose Reveal Layer Source in Project. The Project 
panel will be brought forward with this footage item selected.

•	 Choose File > Interpret Footage > Main, and set Frame Rate >  
Conform Frame Rate To so it matches your original fractional frame  
rate (i.e., 29.97 in this case).

•	 If you extract any 3D scene data from the CINEWARE layer in your 
composition – such as the camera move, which you will in the next 
exercise (Step 25) – select that extracted layer and choose Layer > Time 
> Time Stretch. Set the Stretch Factor to 100.1: This slows down the 
extracted data back to the original fractional frame rate (i.e., 30 to 29.97).

(There is a possibility that you may not need to perform the Stretch Factor  
adjustment in future versions. We’ll update this book’s online page at  
www.routledge.com/cw/meyer if that’s the case.) 

Yes, that last step was tedious, but crucial to make sure your C4D animation 
does not fall out of sync with the rest of your After Effects composition.

5	 Transcribe your After Effects 
composition’s frame size into 
C4D Lite’s Render Settings.

8 continued  You also need to stretch any animations you extract from .c4d layers 
by 100.1%. You can stretch layers either in the Layer > Time > Time Stretch dialog 
(left), or by revealing the Stretch column in the Timeline panel (above).

4	 In C4D Lite, choose Edit > Project Settings from its Main 
menu. It will open in the Attributes Manager in the lower right. 
Set the Maximum Time and Preview Max Time to equal the 
last frame number in your After Effects comp. Copy your frame 
rate into the FPS field. Note that CINEMA 4D does not support 
fractional frame rates; 29.97 gets rounded to 29(!) – so set it to 
the nearest whole number (60 for 59.94, 30 for 29.97, or 24 for 
23.976), and we’ll fix the difference in After Effects. You’ll also 
note at the bottom of this dialog that Linear Workflow has been 
enabled and the Input Color Profile has already been set to sRGB.

5	 Click on Edit Render Settings from the main icons above 
the Viewport, or choose Render > Edit Render Settings. Choose 
Output along the left and change Output > Width and Height to 
match your After Effects composition in pixels. Ignore the Image 
Resolution warning that appears; the connection between C4D 
Lite and After Effects is resolution independent. In general, this 
panel pertains to rendering frames directly out of C4D Lite;  
we’re only setting the frame size here so CINEMA 4D’s viewer 
shows you the correct aspect ratio when you arrange your objects. 
Close this dialog when finished.

4	 Transcribe your After Effects composition’s frame 
rate and duration into C4D Lite’s Project Settings 
(you may need to round up the frame rate to the 
nearest whole number). 

6	 When you return to After Effects, 
you will see the ground plane grid 
from C4D in your Comp panel.  
Clip FCL220 courtesy Artbeats.com.

6	 Choose File > Save from the Main menu. You 
must save your changes in C4D Lite for them to 
appear in After Effects. Then return to After Effects: 
You will see a grid overlaid in your composition; 
this is the ground plane in your C4D layer. Also 
note that your .c4d file appears as a source in  
After Effects’ Project panel; feel free to move it  
into your Sources or Media folder. 



Excerpt from After Effects Apprentice 4th Edition for AE CC. Copyright 2016 Trish & Chris Meyer. Published by Routledge/Focal Press. ISBN: 978-1-138-64308-6. Excerpt from After Effects Apprentice 4th Edition for AE CC. Copyright 2016 Trish & Chris Meyer. Published by Routledge/Focal Press. ISBN: 978-1-138-64308-6. 

4	 Click and drag the three Camera tools in the upper right of the 
Viewport to fit the rounded rectangle outline inside your display.

3	 Create a new Rectangle (above) and size 
it to match your video’s aspect ratio (below).

5	 Add an Extrude object (left), and drag Rectangle on top of it (center) 
so it becomes a child of Extrude (right). 
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5	 You want to turn this outline into an object with volume 
and depth. To do that, you’ll use the Extrude object. Click 
on the Generators icon (its tooltip will say Subdivision 
Surface), and choose Extrude. (You can also choose Create > 
Generators > Extrude from the Main menu.) In the Objects 
Manager, click on Rectangle and drag it onto Extrude; 
watch for the cursor to change to a downward-pointing 
arrow, which indicates the object you’re dragging is about 
to become the child of the object underneath the cursor. 
Release, and now you’ll see a gray slab in the Viewport. 

Click the Toggle View icon in the upper right corner of the 
Viewport to see the Perspective view along with the Top/
Right/Front all at the same time. If necessary, pan and zoom 
the other views to make sure you can see the entire rectangle.

Part 1: Creating a Videowall
A common motion graphics task is to create a virtual “videowall” and to move 
around it. In this exercise you will create a simple model from scratch and 
“texture” it with a sports video.

1	 In After Effects, close your previous comps. In the Project panel, open  
Comps > 02-Videowall*starter. Open Composition > Composition Settings  
and note the frame rate (29.97), frame size (960×540), and duration  
(10 seconds × 30 fps = 300 frames) of the comp, and close the dialog.

2	 Choose Layer > New > MAXON CINEMA 4D File. Change the name to 
“Videowall.c4d” and save it alongside Lesson_12.aep. 

•	 Update C4D Lite’s Project and Render Settings as outlined in first exercise’s 
Steps 4 and 5 (page 364). Save your C4D Lite project and return to After Effects. 

•	 Locate Videowall.c4d in the Project panel, choose File > Interpret Footage > 
Main, and enter “29.97” for Frame Rate > Conform Frame Rate To. Save your 
After Effects project and return to C4D Lite.

3	 We want to create a rectangular videowall face that has the same aspect ratio 
as the video we plan to map onto it. To start, click on the Spline submenu icon 
above the Viewport (its tooltip will say Freehand), and choose Rectangle. (You 
can also choose Create > Spline > Rectangle from the Main menu.) A Rectangle 
object will be added to the Objects Manager, and a square outline will appear 
in the Viewport centered at the origin (0,0,0). When that object is selected, its 
parameters will appear in the Attributes Manager.

With Rectangle selected, click the Object tab in the Attributes Manager and 
set its Width to 960 and Height to 540 to match the aspect ratio of the comp 
and video (you can ignore units like “cm”). To make the corners more interest-
ing, enable the Rounding checkbox; the initial Radius value of 50 is fine for now. 

4	 The outline may be larger than your Viewport display, so it’s time to get 
familiar with zooming and panning around it. There are four icons in the 
Viewport Navigation section in the upper right corner; you can click and drag 
the three leftmost ones to pan, zoom, and rotate your view, akin to After Effects’ 
Camera tools. You can also press and hold down 1, 2, or 3 as you click 
and drag to get the same actions. Pan and zoom the rectangle so you can see it 
comfortably inside the Viewport (see figure on opposite page), with some room 
around the edges.

If you accidentally deselect your model, select Rectangle in the Objects 
Manager or click its outline in the Viewport. 

Move 
Camera 

(1)

Zoom 
Camera 

(2)
Toggle 
View

Rotate 
Camera 

(3)

g  To use a hotkey, press and hold down  
the key then drag the mouse in the viewer.

5 continued	
The rectangular 
outline will now 
be extruded into 
a gray slab.

g  Click the Toggle 
View icon in the 
upper right corner of 
the Viewport to see 
the Perspective view 
along with the Top/
Right/Front all at the 
same time. Click the 
Toggle View icon in 
any individual view 
(Top view is circled) 
to solo that view.


