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This bonus chapter for Creating Motion Graphics 4th
Edition (CMG4 for short) covers the major differences

between After Effects CS3 and CS4. It is organized according
to the chapters in CMG4 which are affected by this update.
We assume that you have already read CMG4, are currently
working your way through it, or are familiar with the content
covered in each of its relevant chapters.

We will be assuming you have After Effects 9.0.1 installed; the version
number can be checked by opening After Effects > About After Effects on
Mac (Help > About After Effects on Windows) and looking at the tiny
numbers under the program’s name. If you are still using version 9.0.0,
choose Help > Update to download the updates to After Effects as well
as the other related programs and modules in Creative Suite 4.
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What’s changed
between CS3 and CS4.

After Effects CS4

Replacement DVDs
If your DVD is lost or damaged,
contact USBkInfo@elsevier.com.
Proof of ownership of CMG4
may be required.

FA C T O I D

Example Project
Copy the contents of the CMG4 DVD onto your local disc drive. Then copy the CMG4CS4 Project folder that
came with this bonus chapter into the Bonus Chapters folder copied from the DVD. Open CMG4CS4 Project
> CMG4CS4.aep. If any files are listed as missing, double-click a missing file in the Project panel (its icon will
resemble television color bars) and locate the file by the same name in the SOURCES folder that also came
from the DVD. After Effects will then automatically find all of the other missing files. 

If you are still using After Effects 9.0.0,
update to 9.0.1 as it includes many bug
fixes plus the ability to use REDCODE
media inside After Effects CS4
(www.red.com/support).

Note that the system requirements 
for After Effects CS4 have changed. 
Most notable for Mac users is that an
Intel processor is required. The full list 
of requirements can be found at
www.adobe.com.products/
aftereffects/systemreqs.
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1 After Effects 101
The user interface received an overhaul between CS3 and CS4. Generally
it is darker and more compact, with updated icons that should be easi-
er to read across a wider range of user interface brightness settings
(adjusted in Preferences > Appearance). Other major changes include:
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The new Welcome screen also offers ways to
open files and access Help resources.

� A new Welcome screen that includes a
searchable Tip of the Day, as well as links
to your most recent projects, the Help
system, and common tasks such as open-
ing Bridge to browse template projects or
other potential source material. It can be
re-opened at any time by choosing Help
> Welcome and Tip of the Day.
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What’s in a Name?
Several panels in After Effects have shorter names 
in CS4. As CMG4 was based on After Effects CS3, 
it obviously uses the original names for these
panels. If you are having trouble finding a panel,
refer to the following chart:

old name new name
Align & Distribute Align
Brush Tips Brush
Time Controls Preview
Tracker Controls Tracker
The Smoother Smoother
The Wiggler Wiggler
Smart Mask Interpolation Mask Interpolation

Bonus Chapter: After Effects CS4 //

The QuickSearch field at the top of the
Project panel replaces the old Find a Project
Item icon.

If you wish to perform a search only inside After Effects Help,
make sure you enable This Help System Only.

Improved Help
Another major overarching feature in After Effects CS4
is an improved Help system. If After Effects detects
an Internet connection upon startup, Help will now
automatically access a much more extensive, regu-
larly updated web-based Help system instead of the
local Help file installed with the program. 

Note that there is more than one help system you
can search, and there are big differences between
them. If you press F1 or choose Help > After Effects
Help in version 9.0.1, you will be placed in the After
Effects-specific Help system; to search only inside
this system, be sure to enable “This Help system
only” when performing a Search on this page. If
instead you use the QuickSearch dialog in the top
right of the Tools panel or choose Help > Community
Help and Support, you will land in a much broader
help system which searches other Adobe help sys-
tems as well as non-Adobe web sites. Community
Help also includes links to useful articles and tutori-
als in addition to the normal Help system.

� QuickSearch fields in the Project and Timeline panels. These
make it much easier to find specific sources or parameters, as well
as comments in these panels (by the way, the Comment column is
now enabled by default in the Project panel). Related to this, the
old Find icon has now disappeared from the bottom of the Project
panel; it has been replaced by using the QuickSearch field in the
Project panel. You can type in the name of the file you are looking
for, characteristics of it such as duration or file extension, or the
special phrases “missing”, “used”, and “not used”.

� The names of comps, layers, footage items, and other elements
are no longer restricted to 31 characters.

� After Effects projects can now optionally be saved using an XML
format (File > Save a Copy As XML). This will be a boon to those
who would like to use scripting to automatically update or modi-
fy projects to streamline production pipelines.
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Some layers can have very long lists of
parameters to search through in the Timeline
panel (above). Using QuickSearch allows you
to reveal just the parameters you’re looking
for (left).

Bonus Chapter: After Effects CS4 //

Helping Hand
If you have a three-button
mouse, use the middle mouse
button to temporarily enable
the Hand tool. This is especially
useful for panning around a
Footage or Layer panel for a
source that may be much larger
than your monitor can handle. 

T I P

2 Creating a Composition
In addition to the QuickSearch dialog mentioned on the previous
page, improvements have been made in the areas of previewing
and working with the Composition panel.

QuickSearch
We discussed QuickSearch in the previous section. To try it out for
yourself, open the CMG4CS4.aep project file and (if necessary)
relink any missing files (the procedure is discussed in the
Example Project box on the first page of this bonus chapter).
Then in the Project panel, twirl open the Chapter 02 folder and
open the comp 02.1 Search Timeline. 

Step 1: This composition contains both text and shape layers,
each of which contain long lists of parameters – making it hard to
find exactly what you want by twirling open layers and scrolling
through the timeline. For example, press Command (Control)
and click on the twirly arrow to the left of the text layer Michael
Kirkland to reveal all of its parameters, then scroll through the
entire list. Pretty daunting! Twirl up Michael Kirkland and try the
same with Shape Layer 1. Twirl it up too when done.

Step 2: To search all layers in the Timeline panel, Edit > Deselect
All (the shortcut is F2). To reveal all the Scale parameters (and
sub-parameters!) in all the layers, start to type “scale” into the
QuickSearch field to the right of the Current Time display in the
Timeline panel. Only the text animator, shape path transform,
and overall layer transform Scale values will be revealed.

Step 3: Click on the X at the right edge of the QuickSearch field
to clear your previous search (you can also select and delete the
characters you had previously typed). All of the layers will auto-
matically twirl back up. 

Step 4: You can also search individually selected layers. Select
Michael Kirkland, and type “position” into the QuickSearch field.
You will see Position offset parameter for Animator 1 (which
would normally take three mouse clicks to reveal), as well as for
the layer’s overall Position in the composition.
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A new Auto setting under Resolution
(top) keeps it in sync with the
Magnification setting in order to boost
efficiency. When you see the Resolution
setting displayed inside parentheses
(above), Auto is engaged.

Previewing
The OpenGL rendering engine used for Fast Previews has been further
refined in CS4. Nested compositions and depth of field blur are among
the project features that may now be accelerated by the GPU (graphics
processing unit) on your video card or in your laptop.

Additionally, OpenGL may also take
advantage of Adaptive Resolution when
attempting to preview images in the
Composition panel. When enabled in
Preferences > Previews, OpenGL will now
work in the same fashion as the Fast
Previews option Adaptive Resolution did
in CS3: If you try to interactively update a
particularly slow effect or composition,
After Effects will temporarily render every
second, fourth, or eighth pixel and line in order to give you a quick idea
of what is going on, and then will render every pixel and line (as deter-
mined by the comp’s Resolution setting) when you release the mouse.

(All that said, personally we still tend to disable OpenGL Fast Previews,
as the result can look different enough from the normal software render-
ing engine that it distracts us. We find Adaptive Resolution to be a bet-
ter choice most of the time.)

To further accelerate OpenGL Fast
Previews (below), turn on the Enable
Adaptive Resolution with OpenGL option
in Preferences > Previews (above).

3 Basic Animation
There have been a few small additions to the way you can manipulate
layers in a composition:

� Flip Horizontal and Flip Vertical commands have been added to the
Layer > Transform submenu. These add a negative sign in front of the X
and Y Scale properties, respectively. They do not affect keyframed values;
if you have animated Scale, a new keyframe will be created at the current
time. (Note that After Effects still has Flip, Flop, and Flip + Flop Animation
Presets. These work by adding a Transform effect to the selected layer,
leaving its Scale value – and its keyframes – untouched.)

Auto Resolution
The Resolution popup along the bottom of the Comp panel now
includes an Auto setting. When Auto is selected, changes to the
Magnification of the Comp panel will result in the Resolution setting
automatically being changed to match. For example, if you set
Magnification to 50%, After Effects will set Resolution to Half to ensure
that only the pixels you see will be rendered. This is the most efficient
way to work. This is the flip side of the old Auto-zoom When Resolution
Changes preference (see page 666 of CMG4). The main gotcha to be
aware of is that some effects look radically different at lower Resolution
settings, so it is a good idea to always go back to 100% Magnification/Full
Resolution to double-check your work before rendering.
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� There are new keyboard shortcuts to alter the Opacity of a selected
layer. Hold Control+Option (Control+Alt) and use the + and – keys on the
numeric keypad to increase or decrease Opacity in 1% increments. Add
the Shift key to jump by 10% increments. (By the way, that’s not a typo; the
Mac keyboard shortcut really is Control+Option, not Command+Option.)

� An additional feature introduced in CS4 is that hovering your cursor
over a keyframe in the Timeline panel will display a tool tip containing
its time and value. Unfortunately, this tool tip does not update if you
drag a keyframe in time; keep an eye on the Window > Info panel to
 verify its new timing.

4 Keyframe Velocity
Normally, After Effects bundles the X, Y, and (if the 3D Layer switch is
enabled) Z Position values into a single keyframe. A major new feature
in After Effects CS4 is the ability to separately keyframe these X, Y, and Z
values. This makes it much easier to keyframe certain types of animation
moves, such as simulating a camera that is both on a dolly and a crane
where you have independent control over its height (Z) and its sideways
or forward motion (X or Z).

Separating these dimensions requires a trip into the Graph Editor.
Once they have been separated, you can edit the new independent
keyframes in either the Graph Editor or the normal timeline display, but
it is easier to see what you are doing in the Graph Editor. 

To gain a better understanding of this feature, let’s work through an
example of animating a bouncing ball. In CMG4CS4.aep, open the com-
position Chapter 04 > 04.1 Separate Dimensions starter. You might
want to keep page 70 of CMG4 open next to you during this exercise to
help remind you of the identity of the various buttons along the bottom
of the Graph Editor.

Step 1: Your goal is to make the baseball in this
composition bounce across the comp’s “floor.”
Select the layer GI_baseball.tif and press P to
reveal its Position property in the Timeline panel.
Then click on the animation stopwatch icon for
Position to enable keyframing for it. 

Step 2: Move the current time indicator to the
end of the comp (the shortcut is to press End).
Drag the baseball to the right edge of the comp
panel and about halfway between its top and bot-
tom (roughly a Position of X=670, Y=263). You will
see a straight motion path in the Comp panel con-
necting your two keyframes.
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Hover your cursor over a keyframe to
display its time and value.
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New and Improved
This new Separate Dimensions
feature replaces the Separate
XYZ Position Animation Preset
discussed in the Advanced
Position Graphs sidebar on
page 81 of CMG4.

FA C T O I D

Steps 1–2: Keyframe the position of the baseball to travel across
the comp panel. Baseball courtesy Getty Images.
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Step 3: In the Timeline panel, located between the
word Position and its animation stopwatch, is a
Graph Editor Set button for this parameter. Click it to
enable it. This will ensure you will always see the
Position property in the Graph Editor, even if you
accidentally deselect the layer.

Step 4: Reveal the Graph Editor in the Timeline panel by clicking its
button along the top of this panel; the shortcut is Shift+F3. Then click on
the Choose Graph Type button along its bottom (to the right of the eye-
ball) and make sure Auto-Select Graph Type is enabled. 

After doing so, you will see a single horizontal white line in the Graph
Editor. This represents the constant speed of the ball as it travels
between your two keyframes. You will also notice that there is just one
Position parameter along the left side of the Timeline panel.

Step 5: Make sure the Position parameter is selected. Then click on the
Separate Dimensions button underneath the Graph Editor. Two things
will happen:
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Steps 3–4: Enable the Graph Editor Set
button for Position (above), then open
the Graph Editor (below).

Step 5: After enabling Separate
Dimensions, separate X and Y Position
values will appear. You will also see
color-coded lines for the X and Y values
and velocities.

� Along the left, the formerly unified Position value will now be replaced
by separate X Position and Y Position parameters, color-coded red for X
and green for Y. 

� In the Graph Editor on the right, the single white velocity graph will be
replaced with separate sloping green and red X and Y Position value graphs.

Step 6: The red X Position value graph has slight kinks at its start and
end caused by the default Auto Bezier keyframe interpolation that was
assigned to it. We want the baseball to keep a steady speed as it moves
from left to right, so let’s convert those to Linear keyframes:

� Double-click X Position to select its keyframes. They will be bound by
a white rectangle in the Graph Editor.

� Click the Convert Selected Keyframes to Linear button along the bot-
tom of the Graph Editor. The X Position value graph will straighten out.



Step 8: Tug on the Bezier handles for 
Y Position in the Graph Editor to create
arcs into and out of each keyframe.
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No Handles?
If your Position keyframes in
the Graph Editor do not have
any handles, they currently
have an interpolation type 
of Linear. To pop out handles,
Option+click (Alt+click) on 
a keyframe to toggle from 
Linear to Auto Bezier.

T I P

You might also notice that the motion path changes slightly in the Comp
panel; when working with Separate Dimensions, your actions in the
Graph Editor directly control your resulting motion path.

� Click outside the white rectangle or press F2 to deselect the X Position
keyframes.

Step 7: Next let’s work on the bounces, which means editing the Y
Position (up and down) graph. First we’re going to set the keyframes for
where the ball hits the floor, then in the next step edit the Y Position
graph to create the flight path between those hits.

� Move the current time indicator to 00:15.

� Scrub the Y Position value until the ball just touches the bottom of
the comp (around Y=436). Don’t drag the ball in the Comp panel; that
would add both X and Y keyframes!

� Make sure just the new Y Position keyframe is selected; it will have a
solid yellow box in the Graph Editor, rather than a hollow yellow box.
Edit > Copy this keyframe.

� Move the current time indicator to 01:15.

� With Y Position still highlighted along the left of the Timeline, Edit >
Paste to create a keyframe at this new time with the same value as the
previous keyframe.

� Move the current time indicator to 02:15, and paste again.

Step 8: A bouncing motion is not continuous; the ball reverses direc-
tion when it hits the floor. This means you need to create discontinu-
ous motion at the keyframes.
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� Bezier handles will be visible in
the Graph Editor around each
keyframe, reflecting their Auto
Bezier interpolation method (the
default). Press the Option (Alt) key
and drag one of the Bezier handles
for the keyframe at 02:15 to
“break” them.

� Now that the handles are bro-
ken for that keyframe, release the
Option (Alt) key and drag each
handle down until you get a nice
arc coming into and leaving this
keyframe. You will see this arc in
both the Graph Editor and in the
resulting motion path in the Comp
panel.

� Repeat to also break the handles and create a steep arc at the
keyframes at 01:15 and at 00:15.

� Edit the curves for the first and last keyframes to help trace out a nice
bounce motion path.

RAM Preview, and continue to tweak until you are happy with your
motion. You can also move the Y Position keyframes in time by dragging
them left and right in the Graph Editor; press the Shift key after you start
dragging to constrain your motion. For example, move the fourth Y
Position keyframe later to shorten the “flight time” during the last
bounce. Note that this does not alter the ball’s speed in the X dimen-
sion; it alters only when it bounces in the Y dimension. Compare your
results with 04.1 Separate Dimensions_final.

Step 9: And now for the magic: Press End and decrease the X Position
value. RAM Preview, and note how the ball doesn’t travel as far across 
the comp, but the up and down bounce motion remains the same.
Without Separate Dimensions, you would have had to tweak each
keyframe by hand.

In general, this animation would have been very difficult to pull off
with normal, joined-together Position values – you would be fighting to
keep a constant speed in X while you created your bounces in Y.
However, using Separate Dimensions does come with a price: You can no
longer directly edit the motion path in the Comp panel (note that the
Bezier handles disappeared); you have to craft your path in the Graph
Editor. The good news is that you can select Position and disable
Separate Dimensions by clicking the same switch along the bottom of
the Graph Editor – After Effects will then approximate your final anima-
tion using traditional joined Position keyframes.
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Step 8 continued: The results will be
reflected in the motion path in the
Comp panel. Remember that the
spacing between the dots in the
motion path indicates how far the
object travels between frames in time.
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5 Animation Assistance
No changes in CS4.

6 The Layer Essentials
There have been two changes to markers in After
Effects CS4. One is that Composition markers now
have all of the same features – including Chapter and
Web links along with Flash Cue Point names and
parameters – as Layer markers. The other is that these
markers can now have a duration assigned to them.
This is handy for annotating events that take several
frames or seconds, such as a car driving by.

The duration is entered in the Layer Marker or Composition Marker
dialog. This dialog opens automatically if you hold Option (Alt) while
creating a Layer marker, or it can be opened later by double-clicking an
already existing marker. After entering a duration, a small “tail” will be
drawn from the marker onward. 

Additionally, there is a new Center in View command in CS4. Select a
layer and choose Layer > Transform > Center in View to have its Position
altered to be centered in the Comp viewer. This is handy for retrieving
layers that get “lost” on the pasteboard after reducing the size of a comp,
or that otherwise have been accidentally placed out of view. The short-
cut is Command+Home (Control+Home).

7 Trimming
No changes in CS4.

8 Motion Blur and More
No changes in CS4.

9 Blending Modes
There are no changes to the modes that can be applied to entire layers.
However, there have been some additions to the modes that can be used
between shapes inside Shape Layers, which we’ll discuss when we get to
Chapter 30.

10 All about Masking
There is one small change in After Effects CS4: When creating or editing
a mask, the Window > Info panel will display how many vertices there are
in the mask (right).

11 All about Track Mattes
No changes in CS4.
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Marker duration is entered in the
normal marker details dialog (above).
This duration is visible as a thin white
line drawn from the marker’s head to
the right. In the second figure (below),
the second marker has a duration, while
the first does not.
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12 Stencils and the “T”
No changes in CS4.

13 3D Space
As we mentioned back in the section on Chapter 6, there is a new Center
in View command in CS4. Select a layer and choose Layer > Transform
> Center in View to have its Position altered to be centered in the Comp
viewer. The shortcut is Command+Home (Control+Home). Note that it
works in the alternate orthogonal and Custom Views in addition to the
normal Camera views. 
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Look at Layers
The opposite of the new
Center in View command are
the existing View > Look at
Selected Layers and View >
Look at All Layers commands.
Instead of moving a layer to 
be visible to the camera, these
commands move the camera
or viewport to look at a layer.

T I P
This comes in handy when you have been manipulating a 3D camera,

and it is now pointing in a direction where you have “lost” a layer. When
executing this command, the layer’s X and Y Position values will be
altered so that it is centered in the Comp viewer, and its Z Position will
be altered so that it appears at approximately 100% of normal size (in
other words, the same size it would be if it was a 2D layer centered in the
current view, give or take some potential perspective distortion).
Experiment with this in the comp Chapter 13 > [13.1 Center in View].

There is one additional change that comes in handy when managing
a multiple-view layout for a 3D composition: If you click on one of the
views in the Comp panel using the middle mouse button, it will not acci-
dentally deselect the currently selected layer or select a different one.

If you have a layer that is off-screen and that you
wish to center (above left), use Layer > Transform >
Center in View to move it (below left). Its Position
value will update (see Timeline above and below).
Video courtesy Lee Stranahan; stills courtesy 
Getty Images.
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14 Cameras
3D cameras have received a few nice enhancements in After Effects CS4,
including integration with a major new feature in Photoshop CS4 Extended.

Unified Camera Tool
One of the most requested, small-
but-important features in After
Effects CS4 is the addition of the
Unified Camera tool. Previously,
you had to keep pressing C to tog-
gle between the Orbit, Track XY,
and Track Z Camera tools. If you
have a three-button mouse, you
can now instead select the Unified
Camera tool and use your three
mouse buttons to quickly switch
between those three tools: Just
click (with the appropriate button)
and drag. If you are in a Camera
view, this will edit the Camera’s
parameters; the Unified Camera
tool can also be used to quickly move around the alternate orthogonal
and Custom Views. Go ahead and try it in Chapter 14 > [14.1 Unified
Camera Tool].

Camera Settings
Another small change that will be a relief to some power users is that
the default units in the Camera Settings dialog now defaults to millime-
ters rather than pixels. This corresponds more closely with real camera
measurements. Note that the Zoom setting in the Timeline panel is still
in pixels, as this relates to the Position and Anchor Point parameters of
a camera that are also in pixels.

Photoshop 3D Layers
In CMG4, we demonstrated on pages 254 and 255 how to use Vanishing
Point Exchange to covert a photograph in Photoshop into a simple 3D
set. Creative Suite 4 offers another way to use Photoshop and After
Effects together in 3D: This time, by importing a 3D model into
Photoshop and then animating it in After Effects. There are some limi-
tations to this technique, but it also offers some interesting possibilities:

Step 1: In Photoshop CS4 Extended, select the menu item File > New.
In the Preset popup, choose Film & Video. Then in the Size popup, select
either NTSC D1 Square Pixel or PAL D1 Square Pixel depending on the
prevalent format in your country. Click OK. (If you don’t have Photoshop
CS4 Extended, jump ahead to Step 9 and use our already prepared
Photoshop 3D Layer file.)
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By selecting the Unified Camera tool
(below), you can use a three-button
mouse rather than the C key to more
quickly switch between the Orbit, Track
XY, and Track Z Camera tools (above).
Footage courtesy Digital Vision.
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Painting in 3D
Using Photoshop to paint on
3D models is beyond the scope
of this bonus chapter. However,
there are some tutorials
available on the web, such as
this one on Photoshop Cafe:
www.photoshopcafe.com/cs4/
3D.htm. You can also search the
Photoshop CS4 online Help file.

FA C T O I D
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Step 2: Select 3D > New Layer from 3D File.
Navigate to the CMG4CS4 Project > CS4_Chapter
Sources folder that came with this bonus chapter,
select TV.3DS, and click Open. After a pause, a styl-
ized TV monitor will appear in the middle of your
new document. Select the 3D Rotate tool from along
the toolbar on the left, then click and drag in your
document window to move around your 3D model.

Step 3: Set Window > Workspace to Advanced 3D.
The 3D and Layers panels will appear along the right
side of your screen. The 3D panel makes it possible
for you to modify the “materials” (surface color and
other characteristics) originally assigned to the
model.

Step 4: In the 3D panel, look under the group
Box01 and select the texture layer N08_Default. This is the material the
model’s creator assigned to the TV’s screen. In the bottom half of the 3D
panel, click on the color swatch for Diffuse and choose a different color.
After a pause, you will see the 3D model’s screen update, as well as any
other surface that has the material N08_Default applied. Change the
color to black, and click OK.

Step 5: TV and monitor screens project light. To assign an image to the
screen to be projected, click on the popup menu to the right of the Self-
Illumination color swatch, and select Load Texture. In the Open dialog
that appears, you can select any image of your choosing, or even a
QuickTime movie! Navigate to the SOURCES > Movies folder that came
from your CMG4 disc, and select one of the files in there such as
AB_Gears.mov. Click Open. If a pixel aspect correction dialog appears,
click Yes. The gears movie will now appear on the TV’s screen.
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Step 2: After importing a 3D model 
into Photoshop CS4 Extended, you 
can manipulate it in 3D space. Model
courtesy Wone Stone and 3dvia.com
through Creative Commons License 2.5.

Step 5: In Photoshop’s 3D
panel, edit the texture
N08_Default (right) by
setting its Diffuse color to
black, and load your own
image or movie as the
Self-Illumination texture
(left). Footage courtesy
Artbeats/Gears.
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Step 6: Unfortunately, the same texture has been applied to both the
screen and the back of this TV model! Note that you are somewhat at
the mercy of the model’s creator when using this technique. Fortunately,
we don’t really need the piece that makes up the back of the TV. So in the
3D panel, disable the group Box02 by clicking on the eyeball to its left.

Step 7: Did you notice that the TV’s outlines are rather jagged? That’s
because the default render quality for the model is set to Draft in order
to make Photoshop more responsive. To improve the appearance of the
model, in the 3D panel select the master group named Scene. Then in
the bottom part of the panel, set the Anti-Alias popup to Better.

Step 8: Select File > Save As. Before you click Save, make sure that the
Format popup in the Save dialog is set to Photoshop and that Layers is
enabled. If a Photoshop Format Options dialog opens after
clicking Save, enable Maximize Compatibility and click OK.

Step 9: Back in After Effects CS4, select the Chapter 14 –
Cameras folder in the Project panel. Then choose the menu
item File > Import > File and select the PSD file you saved
above. (Our version is saved in the CS4_Chapter Sources
folder as Photoshop 3D TV.psd.) After clicking Open, a sec-
ond dialog will appear. Make sure that the Import Kind
popup is set to Composition – Cropped Layers, and that
the Live Photoshop 3D option is enabled. Then click OK. 

Two items will be created in the Project panel: a folder
and a composition named after your file. (Our version is
[14.2 Live Photoshop 3D].) Double-click this comp to open
it. If you find the guides distracting, disable View > Show
Guides.

Step 10: In the Timeline panel, you will see four layers. Starting at the
bottom:

� Background is a white solid filling the frame; you can turn off its Video
switch or delete it altogether.

� TV is the layer that contains a special Live Photoshop 3D effect that is
rendering the 3D model (select this layer and press F3 to see it in the
Effect Controls panel). You can apply additional effects to this layer, as
well as alter its Opacity. If you applied a movie as a texture to the TV
screen, the layer’s duration will be truncated as necessary to match.
Move the current time indicator and note how the image updates.

� TV Controller is a null object that controls the position and orienta-
tion of the layer. Twirl it open to reveal its Transform properties; these 
are what you should edit and keyframe to move the 3D model. (You can
turn off its Video switch – the eyeball icon – to hide its outline in the
Comp panel.)

� Camera 1 is a normal After Effects 3D camera. Use the Camera Tools
to move the camera around your 3D model.
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Step 9: When importing a PSD file with
a 3D layer into After Effects CS4, make
sure that you import as a composition,
and that Live Photoshop 3D is enabled.
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Step 10: The resulting composition
contains four layers. The TV layer
contains a plug-in that does the
rendering; the TV Controller layer is
the layer you should use to animate 
the 3D object’s Transform parameters.
(After Effects automatically linked the
controller to the 3D plug-in for you
using expressions.)

This is a lot of fun. But it must be noted that there are also shortcom-
ings with the current implementation of Live Photoshop 3D, including:

� The 3D model does not react to 3D lights created in After Effects, nor
with other 3D layers (no intersections, no shadows, et cetera). 

� You cannot assign After Effects layers as textures to your 3D model,
nor animate those textures from inside After Effects.

� Any changes to the 3D model – including changing its render quality
settings – must be done back in Photoshop. Select the layer with the Live
Photoshop 3D effect applied (TV in this case), choose Edit > Edit Original
to re-open it in Photoshop, make your changes, save, and return to After
Effects. 

15 Lighting in 3D
3D lighting received only minor updates in After Effects CS4. For exam-
ple, each Light Type now has its own icon in the Composition panel; 
previously, lights looked very similar except for the cone wireframe on a
Spot light.

Additionally, the new keyboard
shortcuts mentioned back in
Chapter 3 to alter a layer’s Opacity
may also be used to alter a light’s
Intensity. Hold Control+Option
(Control+ Alt) and use the + and –
keys on the numeric keypad to
increase or decrease Opacity in 1%
increments. Add the Shift key to
jump by 10% increments. (Again,
that’s not a typo; the Mac key-
board shortcut really is Control+
Option, not Command+ Option.)

Parallel

Point Light

Spot Light
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16 Parenting Skills
No changes in CS4.

17 Nesting Compositions
After Effects CS4 sports several very useful enhancements for navigating
chains of nested compositions: the Composition Navigator, the Mini-
Flowchart, and expanded Edit This/Look At That (ETLAT) functionality.
Twirl open the Chapter 17 – Nesting Compositions folder in the
CMGCS4.aep project, and have fun exploring these features.

Composition Navigator and Mini-Flowchart
The Composition Navigator is a new user interface element that has
been added to the top of the Composition panel. Before you proceed,
first close any previously opened comps by selecting Close All from the
Comp panel’s dropdown menu.

Step 1: Open the comp [17.1a-Master Composite]. Look along the top
of the Composition panel, just above the image area: You will see a string
of comp names. These compositions are nested into each other.

Step 2: Click on the middle comp’s name in the Composition
Navigator. This comp will open. Click on the third comp in the chain to
open it. (If the chain is too long to be displayed along the top of the
Comp panel, you will see “…” at the left or right edge of the chain; click
on the … or use your mouse’s scroll wheel to navigate the entire chain.)

16
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The Composition Navigator is displayed
along the top of the Comp panel. Click
on a comp’s name to jump directly to it,
or click on the arrow to the right of a
comp’s name to open the more
complete Mini-Flowchart.

Show Composition Navigator

If the Composition Navigator is
not visible along the top of the
Composition panel, click on the
options arrow in the upper right
corner of the Comp panel and
enable Show Composition
Navigator (above). Note that
you can also use this menu to
select which way the chains of
comps flow in the navigator.

T I P

A shortcoming of the Composition Navigator is that it shows just one
“thread” of a chain of nested comps. If there are more than two compo-
sitions nested into the currently forward comp, After Effects displays the
name you opened most recently.

Step 3: Click on the Composition Navigator button for [17.1a-Master
Composite] to bring it forward again. Then click on the arrow to the right
of its name in the Composition Navigator: The Mini-Flowchart will open.
This shows all of the compositions connected to the currently selected
comp. Click on one of the arrows along the right edge of the Mini-
Flowchart to see the full extent of a specific branch of the comp chain.
Click on a comp’s name to open it. Have fun experimenting with using
the Mini-Flowchart to navigate up and down these comp chains.

Step 4: The Mini-Flowchart opens centered on the mouse cursor’s cur-
rent location. To open the Mini-Flowchart somewhere other than the
top of the Comp panel, make sure either the Comp or Timeline panel is
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forward, position your mouse, then tap the Shift key to open the Mini-
Flowchart. Clicking anywhere outside the flowchart closes it without
changing which comp is currently forward. 

There are two additional changes between CS3 and CS4 that affect
how you navigate nested compositions:

� In the Timeline panel, the Open
Parent Comp button has been
replaced with a button that opens
the Mini-Flowchart (right).

� Double-clicking a nested comp in the Timeline now opens the nest-
ed comp. Previously, it opened the Layer panel for the nested comp. To
open the Layer panel instead, hold Option (Alt) when double-clicking a
layer that is a nested comp.

Edit This, Look At That
Enhancements have also been made to the “Edit This, Look At That”
(ETLAT) behavior in After Effects CS4. Previously, you could lock the
Effect Controls panel of a layer used in one comp, then bring another
comp forward. This allowed you to edit an effect’s settings inside a nest-
ed comp while viewing the results in a downstream comp. As of CS4,
you can now also lock the Comp panel for a downstream comp, then
edit layers in the Timeline panel for a nested comp.

We know – that’s a confusing statement to read. It’s much easier to try
it out for yourself:

Step 1: Continuing from the prior exercise, make
sure both the [17.1a-Master Composite] and
[17.1c-Wheel single rotate] comps are open in the
Timeline panel.

Step 2: Bring [17.1a-Master Composite] forward
and click on its lock icon to the left of its name
along the top of the Comp panel. The lock will turn
yellow.

17
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When there are multiple nested comps connected to the
current composition, you can click on the path arrow
along the edge of the Mini-Flowchart (left) to reveal that
chain’s full path (below). When a comp is nested more
than once into another comp, the number of times it is
nested is displayed in parentheses after the comp’s
name (circled in red below).

Most Recent Comp
To open the most recently
active nested composition
without going through the
Mini-Flowchart, hold Shift and
tap Escape. Repeat to return 
to the previous comp.

T I P

Click on the lock icon in the Comp panel
to always view this comp while
exploring the timelines of nested
compositions.
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Step 3: Select the tab in the Timeline panel for the nested
comp [17.1c-Wheel single rotate]. Its timeline will come for-
ward, but the Comp viewer for [17.1a-Master Composite] will
still be displayed.

Step 4: In the Timeline panel for [17.1c-Wheel single rotate],
select the layer CM_bikelayer.tif. This one layer is replicated
numerous times in the comps downstream. Apply Effect >
Distort > Twirl, and increase its Angle in the Effect Controls
panel. When you release the mouse, in the Comp viewer you
will see that all of the wheels will have their spokes twirled.

Step 5: Click on the tab for [17.1a-Master Composite] to bring its
Timeline panel forward again. Then tap the Shift key to open the Mini-
Flowchart. Select [17.2a-Numbers composite] to open its Timeline.
Select any of the first three layers and use the cursor keys to nudge their
position in this nested comp. The Comp viewer will update to show their
new position in context with the bike wheels in the master comp.

Step 6: To return to normal behavior, click on the
lock icon in the Comp panel to unlock [17.1a-Master
Composite]. The comp you were working in – [17.2a-
Numbers composite] – will now be displayed in the
Comp viewer.

This trick will save you from having to open two
Timeline and Comp panels while working with tricky
chains of nested comps. Note that in our example we
opened a series of nested comps, locked the master
comp, then used the tabs along the top of the
Timeline panel to bring forward the timeline we
wished to edit. However, after you lock the master
comp, if you then switch to another comp using the
Composition Navigator along the top of the Comp panel, the newly
selected  comp will then become the “locked” comp. Another variation
occurs if you open a composition from the Project panel when one
comp is locked: The new comp will open in a new Comp viewer docked
inside the same frame (try this, and notice the additional tab at the top
of the Comp panel). Even if a comp is already open, double-clicking it in
the Project panel will open it in a new Comp viewer. So if you like the
original behavior, be sure to bring a comp forward by clicking its tab in
the Timeline panel only. 
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18 Precomposing
No changes in CS4.

19 Collapsing Transformations
No changes in CS4.

With the master comp’s viewer locked,
you can edit layers in nested
compositions (above) while viewing the
result in the master comp (below). You
can even RAM Preview while a nested
comp is forward; the master comp is
what will be rendered. Background
footage courtesy Artbeats Digital Biz
and Liquid Ambience.
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20 Textacy
There were two small but nice additions to the text
capabilities in After Effects in version CS4:

Text to Masks or Shapes
In After Effects 7, you could convert a text layer to a
solid that contained a series of masks that corre-
sponded to the characters in the text. This allowed
you to animate the individual vertices of the charac-
ter shapes.

In After Effects CS3 – where Shape Layers were
introduced – this featured changed so that instead of
a solid with masks, a shape layer was created with a
series of shape paths that corresponded to the indi-
vidual characters. (Some of the fun you can have with
this feature is demonstrated in CMG4 in Chapter 30,
page 492.)

In After Effects CS4, you now have
the option to create either solids with
masks or to create shape layers. Select
a text layer (such as the first layer in
Chapter 20 > [20.1-Create Outlines]),
choose either Layer > Create Shapes
from Text or Layer > Create Masks from Text, and have
fun animating the shapes of the individual charac-
ters. We personally prefer the Shapes option as more
of the styling of the original text (such as its stroke)
remains intact. On the other hand, the Masks option
allows you to apply effects that use mask shapes such
as Audio Waveform, Scribble, Vegas, and Stroke.
(Either type of path can also be copied and pasted as
a motion path to Position or Effect Point properties.) 

New Stroke Options
Shape Layers enjoy a variety of “line join” options for
their strokes. These define what happens when an
outline hits a corner. In After Effects CS4, text strokes
now have the same options.

Open Chapter 20 > [20.2 Text Stroke]. Note that the
text outlines currently have very squared-off edges,
both inside and outside the characters. Select the text
layer miter, and open Window > Character. Click on
the options arrow in the upper right corner of the
Character panel and select the menu option Line
Join: It is currently set to miter, which is the default.
Choose the option Line Join > Bevel, and the squared-
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In After Effects CS4, text can be
converted to either Shape Layers or
mask shapes applied to a white solid
(left). The Shapes option retains the
original color and stroke of the text
(above) plus allows you to apply 
Shape Effects (Chapter 30). Footage
courtesy Artbeats/Ocean Water Effects.

Click on the Options menu for the Character palette to
control what happens to text strokes at sharp corners. 
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off edges will gain an extra “cut” to them. Choose the option > Round,
and they will now have a soft rounding applied.

21 Applying and Using Effects
After Effects CS4 offers a few minor updates to the way you can use
effects:

� The new shortcut key FF (two Fs in quick succession) reveals missing
effects in the current composition’s Timeline panel. This will be a huge
help for those who open archived projects (or projects inherited from
others), get the dreaded message that some third-party effects are miss-
ing, and have no idea which layers use those effects.

� Previously, pressing Command (Control) and clicking on the twirly
for a layer in the Timeline panel revealed all of its parameters as well as
the contents of all of its parameter subgroups. You can now do the same
for an effect in the Effect Controls panel: Hold Command (Control) and
click an effect’s twirly, and its parameter subgroups will open as well.

� Adjustment layers have a
default label color, which
makes it easier to identify
them or select them by label
group. The color assigned can
be changed in Preferences >
Label Defaults and > Label
Colors.

� There is now a keyboard
shortcut to create a Layer >
New > Adjustment Layer:
Command+ Option+Y
(Control+Alt+Y).

20

The three choices are Miter (left), Bevel
(center), and Round (right).

Bonus Chapter: After Effects CS4 //

Miter Bevel Round

Command+click (Control+click) on 
an effect’s twirly to reveal all of its
parameters in the Effect Controls panel.
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22 Effects Roundup Overview
After Effects CS4 gains three new effects, which are discussed in the next
section. Several of the previous effects have also been updated to work
in 32 bit per channel floating point mode – most notably, all of the 3D
Channel effects (covered in Bonus Chapter 38B on CMG4’s DVD-ROM).

If you are interested in rolling your own effects, After Effects CS4 can
also load and run plug-ins written using the new Pixel Bender toolkit.
Pixel Bender is Adobe’s own language for creating effects that can func-
tion on either the GPU (graphics processing unit on your
video card) or your computer’s normal CPU. Pixel
Bender effects can also be run in other Adobe applica-
tions including Flash Player and (eventually) Photoshop. 

The Pixel Bender Toolkit (including documentation
and demo files) is included with After Effects CS4. On the Mac, it is
installed in Applications > Utilities > Adobe Utilities; on Windows it is in
Program Files\ Adobe\Adobe Utilities. (You can also find information
on labs.adobe.com/technologies/pixelbender.) It is hoped that individu-
als and third parties will write effects using this language and make them
available to other users.

22B Effects Roundup 
(Bonus Chapter PDF on DVD)

Three new effects have been added in After Effects CS4: Cartoon,
Bilateral Blur, and Turbulent Noise. All are GPU-accelerated and based
on the technology introduced in Adobe’s Pixel Bender language (see the
previous section for more on Pixel Bender). Examples of all of these
effects can be found inside the Chapter 22B folder.

Cartoon
The Cartoon effect re-creates that cartoon-from-live-action look that’s
been popular in some commercials and movies during the past few
years. Cartoon is relatively easy to use with few parameters to learn, plus
it is GPU-accelerated so that it’s very responsive.

Cartoon can be thought of as
working in three steps:

� Smoothing the image to remove
the details that pegs an image as
being “realistic.”

� Finding the edges between the
remaining details and stroking
them to help separate the areas of
color.

� Filling in colors and gradients
between the above edges.

21
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Open the comp [22B.1-Cartoon starter] and try it yourself:

Step 1: Select the layer AB_FamilyLife.mov and apply Effect
> Stylize > Cartoon. The initial results may look a bit coarse –
but you’re not reading this just to learn how to use the default
settings…

Step 2: In the Effect Controls panel, hold down the
Command (Control) key and slowly scrub the value for Fill >
Shading Steps to the left. Lower Shading Steps values result in
a starker, less realistic, more posterized look; the sweet spot is
between 2 and 3.

Step 3: Decrease Fill > Shading Smoothness. On this partic-
ular clip, you will go through some interesting stylized artis-
tic looks in the 60s range until you reach some Sunday
morning–comics looks in the 50s range. Other clips will
respond differently, but in general lower values result in 
posterization, while higher values result in more realism.
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Cartoon may appear to initially have little effect (above) on
the original footage (above left). However, just a few minutes
of experimentation can yield bright, bold looks (below).
Footage courtesy Artbeats/Family Life.

Cartoon has relatively few controls, making it
easier to master.

Step 4: Increase Detail Threshold to add a blurred
look to the image. At extreme values, all details in the
faces will disappear. Use Detail Radius to fine-tune
the result.

Step 5: Decrease Edge > Width to use thinner lines
to define the edges between fields of color. Edge >
Threshold decides how many lines there are. If you
prefer a “softer pencil” look, increase Edge > Softness;
then slowly increase Edge > Width to recover your
lines. 

These controls interact with each other; feel free to
go back and re-tweak previous settings to further
alter the look. For example, go back and increase Fill
> Shading Steps at this point to get some detail back
in the final image.
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If you’re having trouble coming
up with a look you like, Cartoon is
a perfect example of an effect that
works well with Brainstorm
(Chapter 24) to explore new looks:

Step 6: Select Cartoon in the
Effect Controls panel. Then click
on the Brainstorm icon in the
Timeline panel (which looks like a
light bulb in After Effects CS4,
compared with the storm cloud in
CS3), and let After Effects generate
some variations for you.

Step 7: If you chose a variation
created by Brainstorm, make sure
you return to the Cartoon effect in
the Effect Controls panel, twirl
open the Advanced section, and if
necessary re-enable Use OpenGL
When Available: The random
functions in Brainstorm may have
turned it off.

Like any effect, Cartoon often
looks best when combined with
other effects. We regularly place
Color Correction > Levels before it
to adjust the brightness of the
image to be processed by Cartoon,
then follow it with an effect such
as Color Correction > Hue/
Saturation to alter the colors in the
result. We’ve done this in [22B.1-
Cartoon_final].
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Cartoon Motion
When using Cartoon, lower the
comp’s frame rate to 12fps (or
even 15fps) to better replicate
the motion in real cartoons.
Enable Composition >
Composition Settings >
Advanced > Preserve Frame Rate
to lock in this slower speed.

T I P

Brainstorm (Chapter 24) can help you explore what Cartoon is capable of (above).

GPU, but Not Multi-Processor
An unfortunate downside of GPU-accelerated effects such as Cartoon
is that they are not compatible with multiprocessor rendering. If you
are using one of these effects in your current composition chain, only
one processor or core will be used for previews and final renders –
even if you have Preferences > Multiprocessing > Render Multiple
Frames Simultaneously turned on, and even if you have Use OpenGL
When Available turned off in an effect such as Cartoon.

Other color correction
effects can be used to
enhance the contrast
and hue of a Cartoon-
processed scene
(left).
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Bilateral Blur
Bilateral Blur blurs color information while keeping grayscale informa-
tion relatively sharp. The result resembles a “smart” blur that preserves
edges while blurring smaller details in-between. By default, Bilateral Blur
reduces the saturation in an image; enable the Colorize switch to get the
color back. The Threshold parameter controls how much detail is
retained, while Radius controls how much the rest of the image is blurred.

At higher Radius or Threshold settings, its GPU acceleration really
kicks in. On the other hand, if you find yourself using lower settings to
get more subtle results, Bilateral Blur can slow down considerably. As a
result, Bilateral Blur is perhaps best for creating stylized looks (includ-
ing creating a variation on the Instant Sex look described on page 2 of
Bonus Chapter 22B); if you are in search of more subtle or “corrective”
treatments such as removing the wrinkles in a person’s face, stick with
the existing Smart Blur effect.
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Bilateral Blur smoothes out an image
while retaining some details. The
original image is (left); the processed
image is (right). Footage courtesy
Harry Marks.

Turbulent Noise
Turbulent Noise is an alternate version of the ever-
popular Fractal Noise effect. The problem with
Fractal Noise is that it’s slow. Turbulent Noise is GPU-
accelerated, so it is much faster, making it far more
interactive to tweak. 

For the most part, you can take any recipes you’ve
developed or learned for Fractal Noise and apply
them to Turbulent Noise, as most of the parameters
are the same. However, there are a few important
 differences:

� Fractal Noise can loop (by enabling its Evolution
Options > Cycle Evolution switch); Turbulent Noise
cannot.

Like Fractal Noise, Turbulent Noise can be used to generate a
wide variety of natural and abstract phenomena. The above
image is created in comp [22B.3a].



22C Particle Playground 
(Bonus Chapter PDF on DVD)

No changes in CS4.

23 Compound Effects
No changes in CS4.

24 Presets and Variations
The only change in After Effects CS4 is that
the icon for the Brainstorm switch in the
Timeline panel has changed from a storm
cloud in CS3 to a light bulb in CS4.
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� Turbulent Noise can initially seem to have less contrast than Fractal
Noise. If you are copying a recipe originally developed for Fractal Noise,
try doubling Turbulent Noise’s Contrast value to get closer to the intend-
ed look.

� Turbulent Noise employs a more accurate simulation, resulting in
smaller noise features moving more quickly than larger noise features
when animated.
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The above images were created using
Turbulent Noise and are included in
example comps [22B.3b] (left) and
[22B.3c] (right).

The Brainstorm icon has a new look in CS4.

Obsolete Effects
As of After Effects CS4, some effects have been
put into semi-retirement: Basic 3D, Basic Text,
Path Text, and Lightning have been moved into a
new Obsolete category. Old projects that use
them can still be opened, but it is suggested that
you no longer use them in new projects. Instead,
you can use After Effects’ built-in 3D and text
engines, as well as the Simulation > Advanced
Lightning effect.



© Creating Motion Graphics � 4th Edition

25 Color Management
Color management has been improved in After Effects CS4 so that it now
recognizes and compensates for the differences between “scene-
referred” and “display-referred” color profiles. The short explanation is
“Don’t worry – CS4 is merely more accurate now. Leave the option File
> Project Settings > Compensate for Scene-referred Profiles enabled
when using color management, and in some scenarios your output will
now be even more accurate than it was before.” For a longer explanation,
read on; these changes affect Photoshop CS4 as well.
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Image States
Some color profiles – such as SDTV, HDTV, Camera Raw, plus many film-
based profiles – are based on how an image appeared when it was orig-
inally captured, and therefore are known as scene-referred. Other color
profiles – such as sRGB, Adobe RGB, Apple RGB, SMPTE C, and others –
are based on how an image is to be displayed, and are therefore known
as display-referred. 

If you think of a typical video workflow, you shoot footage outdoors in
sunlight or with the assistance of additional lighting, and the contrast (or
“dynamic range”) between the brightest light and darkest shadow is con-
siderable. However, a typical television does not have nearly the dynam-
ic range available on a set, so the final image will inevitably be displayed
with reduced contrast and potentially altered colors. As a result, when
you shoot a scene on (for example) a high definition camera, its output
– which is in the HDTV Rec. 709 color space – will be “tone mapped”
(have its dynamic range reduced) by a high definition television so that
the source image can be displayed in its own sRGB color space. A side
effect of this is that the image will typically appear darker on TV than it
was on the set.

This becomes an issue when viewing HD (and other scene-referred)
sources on your computer monitor in After Effects: You would prefer to
see it as it would ultimately appear on its corresponding display device
(in this case, a high-def TV). To accomplish this in CS3, you would use
the View > Simulate Output > HDTV (Rec. 709) option to perform this

By enabling File > Project Settings >
Compensate for Scene-referred Profiles
(above left), After Effects CS4 will
properly translate between color
profiles that describe how a footage
item was shot versus profiles that
describe how a footage item will be
displayed. This option also exists in
Photoshop CS4 under Edit > Color
Settings (above right).
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tone mapping. In After Effects CS4, instead you can just enable File >
Project Settings > Compensate for Scene-referred Profiles. Note that in
CS4, this adjustment will take place automatically regardless of which
combination of scene- and display-referred profiles you are using – in
CS3, you would need to change the Simulate Output settings to match
your viewing format. In either case, HDTV source material will now
appear darker on your computer monitor while working with it in After
Effects, matching what an HD television would do to the image. An
important under-the-hood detail is that the underlying pixel values will
not be changed, which means you don’t have to worry about color shifts
in sources passed straight through After Effects.

Mixing Profiles
The second part of this issue comes in combining output-referred
source material – such as digital photographs that have already been
saved in the output-referred sRGB or Adobe RGB color space – with
source material that has a scene-referred profile, such as SDTV or HDTV
footage. As these additional sources already exist in an output-referred
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Adobe White Paper
Adobe has created a document
that further explains the 
“image state adjustment” that
After Effects CS4 performs
between scene- and display-
referred color profiles. Go to
www.adobe.com/go/learn_ae_
sceneoutputreferredpaper.

FA C T O I D

space, unlike your video they do not need additional adjustment to 
compensate for how they will ultimately be displayed (aside from any
necessary translation from one output-referred space to another, such
as from Adobe RGB to sRGB).

To see this in action, close all previous comps by selecting Close All
from the Comp panel’s dropdown menu. Then open the File > Project
Settings for CMG4CS4.aep. Under Color Settings set Working Space to
SDTV NTSC, and for now disable Compensate for Scene-referred
Profiles. Click OK; color management will be enabled, and you will be
working in a mode similar to After Effects CS3 with Output Simulation
turned off.

Open the comp [25.1-Scene vs. Output Referred]. It contains two
sources: PM_Alex_keyed.tif, which is keyed video footage that has been
assigned a color profile of SDTV NTSC (which is scene-referred), and

In After Effects CS3, video-sourced
footage (such as the keyed woman in
the foreground here) will be displayed
using its scene – rather than output –
profile, causing it to appear artificially
bright (above left). In CS4, the
Compensate for Scene-referred Profiles
option will display scene-referred video
footage darker, while maintaining
output-referred sources such as the
background photo here (above right).
Woman courtesy Photron.
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the still image background CM_BigMorongo.jpg that has been assigned
a color profile of Adobe RGB (which is output-referred). You might notice
that Alex looks a little bright in this composite. That’s partially because
you are viewing her as she was shot on the set. In a normal broadcast
chain, a television set would display her darker than that.

Re-open File > Project Settings, and enable Compensate for Scene-
referred Profiles. Click OK, and now Alex will appear darker in the Comp
panel: After Effects is compensating for how she will appear to a viewer
on a properly calibrated television set (in this standard definition case,
one that conforms to the SMPTE C color specification).

Why didn’t the background photograph get darker as well? Because it
is already output-referred, meaning it has been pre-compensated for
how it will appear when displayed. You don’t want After Effects to throw
a second output compensation on top of that; the result would be
wrong. Instead, all After Effects has to do in this situation is translate the
source’s Adobe RGB color space into the desired output space.

Yes, this is a confusing subject – but it is an important issue, and one
that After Effects CS4 is taking into account for you automatically (as
long as you have the Project Settings option to Compensate for Scene-
referred Profiles enabled!). In addition to the SDTV and HDTV cases,
this scene- versus output-referred compensation will also take place for
color-managed film projects. 

(When you’re done with this section, you can set File > Project Settings
> Working Space back to None to work through the rest of the exercises
in this bonus chapter.)

26 Keying
No changes in CS4.

26B Color Difference Keyer 
(Bonus Chapter PDF on DVD)

No changes in CS4.

27 Frame Rate Manipulation
This is not a new feature, but a minor errata for CMG4: On page 452 in
the sidebar titled Timewarp, we mention that the After Effects Timewarp
plug-in is based on the Kronos plug-in from The Foundry. Unfortunately,
the link we gave to get the documentation from its website no longer
works. Instead, go to www.thefoundry.co.uk, and click on Plug-Ins >
Final Cut Pro > Furnace. Download the User Guide (under the Support
& Training menu in the right column of this page), and jump to page 31
of the PDF (page number 23 in the document) where the Parameters
explanation begins. As the parameters in Timewarp are very similar to
Kronos, this explanation will give you a good background in how
Timewarp works and how to fine-tune it for your particular job.
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Taking Stock
The list of film stock color
profiles has been updated in
After Effects CS4, including the
addition of a Universal Camera
Film Printing Density profile.

FA C T O I D
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28 Motion Stabilization
See the comment for Chapter 29 on the inclusion of Mocha for After
Effects from Imagineer Systems.

29 Motion Tracking
A major addition in After Effects CS4 is that the stand-alone 2.5D planar
tracking and stabilization program Mocha for After Effects from
Imagineer Systems is now bundled with CS4. Rather than tracking indi-
vidual points in an image, with Mocha you define the general outline of
a plane of an object. Mocha tracks the shape of this plane to determine
its location, size, and orientation. The resulting tracking data is then
exported as Corner Pin data, which can be pasted into After Effects. It is
resolution independent, and can import Cineon, DPX, TGA, TIF, JPEG,
PNG, SGI, and QuickTime files with a depth of 8 or 16 bits per color
channel.

Mocha offers many features that the tracker and stabilizer in After
Effects does not offer, such as the ability to create hold-out masks to
ignore objects that might throw off the track, as well as to define a

29

Bonus Chapter: After Effects CS4 //

Mocha for After Effects – bundled with
CS4 – offers tracking and stabilization
capabilities that go beyond the point
tracker in After Effects. Be warned,
however, that it is a stand-alone
program with quite a different user
interface than After Effects’. Footage
courtesy Artbeats/Medical Surgeries.
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 specific area to paste into, which may not be the same as the area you are
tracking (those who have had to offset corner pin tracks in After Effects
know what we’re talking about). Mocha is also good at following objects
that go partially off screen during a track. 

As Mocha is a beast onto itself, teaching it is beyond the scope of this
bonus chapter. Note that Mocha’s user interface and way of working is
quite un-After Effects-like; be prepared to spend some time mastering it.
Fortunately, Imagineer offers documentation and video training online:
Visit www.imagineersystems.com/products/mocha-AE/ for more infor-
mation. Here is the general workflow:

� Track or stabilize the footage in Mocha.

� Choose File > Save Tracking Data. In the case of a perspective motion
track, make sure the Format popup at the top of the resulting dialog says
After Effects Corner Pin Data (*.txt). The window below will then contain
the text needed to paste into the corresponding Corner Pin keyframes
inside After Effects.

� Click Save and choose where to save your tracking data.

� Open the file you just saved in a text editor, select all of the text, and
Copy.

� In After Effects, create a comp with the footage that was tracked, and
the footage you wish to composite on top of your tracked scene. 

� Select the footage you wish to composite, and apply Effect > Distort >
Corner Pin.

� Press Home to ensure that the current time indicator is at 00:00. Paste,
and the corner pin data from Mocha will be applied to this layer. This
layer will now be distorted correctly – but it may not be centered over the
window. If necessary, offset the layer’s Anchor Point so that the new
footage aligns with the desired location in the tracked scene underneath.
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CC Power Pin
When performing a perspective track, some prefer 
to use Distort > CC Power Pin in place of the normal
Adobe Corner Pin effect: It is more flexible, and some
feel it resamples the layer with higher quality. 

To do so, first use Animation > Apply Animation
Preset and choose the file CMG4CS4 project >
mochaPowerPin.ffx. This applies both the Corner
Pin and CC Power Pin effects. Corner Pin is disabled,
while CC Power Pin gets its parameters from the
Corner Pin effect. Apply your perspective track data
to Corner Pin, and CC Power Pin will actually render
the layer.
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30 Shape Layers
A very nice update to shape layers in After Effects CS4 is the addition 
of the Wiggle Transform shape effect. This effect randomizes and auto-
 animates the transform properties – Anchor Point, Position, Scale, and
Rotation – of the components of a shape group. It works particularly well
in conjunction with the Repeater shape effect. However, there are a cou-
ple of things to be aware of when using Wiggle Transform that we’ll cover
in the next two exercises. Both of these reside inside the Chapter 30 
folder in CMG4CS4.aep.

Wiggle Transform
First you will learn how Wiggle Transform works, 
and what to do if you want to wiggle more than one
property.

Step 1: Open [30.1-Wiggle Transform starter]. It
contains a single shape layer named Jellybean. Your
goal is to make Jellybean wander automatically
around the screen.

Step 2: Twirl down Jellybean > Contents to reveal
the shape group named Shape 1. Select Shape 1 to
ensure your shape effect will do inside this group, and
choose Add > Wiggle Transform.

Step 3: Twirl down Wiggle Transform 1 > Transform.
All of its transform offsets default to zero. Set Wiggle
Transform 1 > Transform > Position to X=300, Y=0 and
RAM Preview: The shape will slide back and forth
horizontally.

Step 4: Set Wiggle Transform 1 > Transform > Rotation to 1x +0.0°. RAM
Preview, and carefully note Jellybean’s behavior: As it moves to the left
(negative X direction), it rotates counter-clockwise (negative rotation);
as it moves to the right (positive X direction), it rotates clockwise (posi-
tive rotation.
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Step 4: When the same Wiggle
Transform effect is used to wiggle both
Position and Rotation, these parameters
move in concert with each other.

32 Bits Per Channel
Shape layers can now be
rendered with 32-bit floating
point fidelity.

FA C T O I D

Steps 2–3: Add the Wiggle Transform
effect to Jellybean’s Shape 1 group, 
and set its X Position to 300.

Here is what is going on underneath the hood: Wiggle Transform
internally generates a single random value, ranging from –1 to +1. This
internal value is then multiplied by the Transform offsets you’ve entered.
If you enter offsets for more than one parameter, they will all change in
concert with one another, as they are being driven by the same under-
lying random value.
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Step 5: By dedicating separate Wiggle Transform shape effects to
Position and Rotation (right), these two parameters will now wiggle
independently from each other (below).

Repeater + Wiggle Transform
The stacking order of shape operators often has a big impact on
the resulting image. This is particularly true with the combina-
tion of Wiggle Transform and the Repeater.

Step 1: Open [30.2-Repeater+Wiggle starter], then twirl open
Pinwheel > Contents > Shape 1. This shape layer contains a sin-
gle ellipse shape that has been repeated to create a pinwheel.

Step 2: Select the group Shape 1 and Add > Wiggle Transform:
It will be added to the shape group after Ellipse Path 1 and before
Repeater 1.

Step 3: Twirl open Wiggle Transform 1 > Transform and enter
some values. The exact numbers don’t matter; we used Y
Position = 20, Scale = 50% and Rotation = 30°. 

RAM Preview: Note that all of the petals in the pinwheel pulse
in unison and that the entire pinwheel shape rotates as a whole.
This is because you are currently wiggling the transform values
for the initial ellipse before it is repeated to create multiple
shapes.

What if you want to randomize, say, Position differently than
Rotation? That will require more than one Wiggle Transform
shape effect:

Step 5: Set Wiggle Transform 1 > Transform > Rotation back to
0x +0.0°. Then select Add > Wiggle Transform again. Twirl down
Wiggle Transform 2 > Transform, and set Rotation for this sec-
ond instance of the effect to 1x +0.0°. RAM Preview; the rotation
will happen independently of the horizontal movement.

Now that you have two Wiggle Transform effects, you have the
additional flexibility of setting different speeds (Wiggle/Second)
for each instance. Go ahead and experiment; if you get lost, our
result is in [30.1-Wiggle Transform_final].

Step 3: When you Add > Wiggle
Transform, note that it is placed before
Repeater 1.
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Step 5: Increasing
Correlation results in the
repeated shapes wiggling
in a wave, rather than in a
random pattern.

More Modes
In After Effects CS4, shape layers now
have a longer list of modes that can be
used to blend together shape strokes,
fills, and groups. The list of additions
includes Linear Burn, Darker Color, 
Linear Dodge, Lighter Color, Linear Light,
Vivid Light, Pin Light, and Hard Mix.

FA C T O I D

Step 3: When Wiggle Transform is before Repeater, all of the repeated shapes will wiggle in unison.

31 Paint and Clone
No changes in CS4.

32 Vector Paint
No changes in CS4.

33 The Puppet Tools
No changes in CS4.

Step 4: Drag Wiggle Transform down the
list so that it is after Repeater 1 and just
before Transform: Shape 1. The pinwheel
will take on a disheveled appearance!

RAM Preview, and each petal will scale,
rotate, and move independently of the
other petals. This is because you are first
repeating the ellipse to create multiple
petals, then wiggling the transform of each
of those petals. (Wiggle Transform wiggles
each component shape of a shape group.)

Step 5: Correlation controls how much
each wiggled shape resembles or varies from
another, with higher values for Correlation
resulting in a higher degree of resemblance.
Increase Wiggle Transform 1 > Correlation
to 90%. RAM Preview, and note how much
more coordinated the actions of the individ-
ual petals appear to be. Composition [30.2-
Repeater+Wiggle_final] contains two copies
of Pinwheel, with low correlation (left) and
high correlation (right).

Step 4: When Wiggle
Transform is after Repeater
(above), each repeated shape
is wiggled individually (right).
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34 Working with Audio
On page 550 of CMG4, we mention in a Gotcha that expressions are not
calculated on audio layers while previewing audio. This behavior is
much improved in After Effects CS4:

� If you create an
expression for a Stereo
Mixer effect applied to
an audio layer (for
example, to make the
Right Channel follow
the Left Channel), the
expression will now be
calculated for the audio
preview for that layer.

� If you create an expression applied to Levels for an audio layer (for
example, to follow a Slider Control to make it easier to adjust or keyframe
Levels for multiple layers), that expression will not be calculated during
an audio preview – at least as of version 9.0.1.

34B Audio Effects
(Bonus Chapter PDF on DVD)

No changes, aside from the comment in the section on Chapter 34 con-
cerning audio previews and expressions applied to the Stereo Mixer
effect (in short: It now works).

35 Expressions
In After Effects CS4, context-clicking on a parameter in the
Timeline or Effect Controls panel now reveals an option to
Copy Expression Only. This makes it easier to copy and
paste expressions between layers by allowing you to leave
behind the underlying value or any keyframes.

35B Deeper Modes of Expression
(Bonus Chapter PDF on DVD) 

No changes in CS4.

35C Scripting Overview
(Bonus Chapter PDF on DVD) 

Scripting continues to evolve in After Effects; refer to the Adobe Scripting
Guide (look online at www.adobe.com/devnet/aftereffects/) for the latest
information. However, the introduction provided by Bonus Chapter 35C
is still valid.

34

Expressions applied to the Stereo Mixer
effect applied to an audio layer will now
be calculated for the audio preview.

Bonus Chapter: After Effects CS4 //

Copy Expression Only allows you to 
copy jthe expression without also
copying the underlying value.
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36 Import and Interpret
Several new media formats may be imported into After Effects CS4:

� FLV and F4V (commonly known as “Flash Video”).

� ASND (Adobe Sound Document).

� Sony XDCAM EX.

� The Sony XDCAM HD version of MXF (the Panasonic P2 Op-Atom
version was supported as of After Effects 8.0.2).

Additionally, a new option has appeared in the Photoshop PSD file
import dialog: Live Photoshop 3D. This was demonstrated earlier in the
section on Chapter 14.

Interpret Footage Shortcut
An annoying new feature in CS4 is that the keyboard shortcut to
open the Interpret Footage dialog for a selected footage item has
changed: It is now Command+Shift+G (Control+Shift+G). 

Note that pressing the old shortcut of Command+F
(Control+F) will instead make the QuickSearch field active (QuickSearch
is discussed in the section on Chapter 2). This means if you type
Command+F (Control+F) by mistake, first you must click somewhere
else to deactivate QuickSearch, then type the correct shortcut. 

Knowing that the new shortcut will be hard to remember, Adobe took
the nice step of adding an Interpret Footage button to the bottom of the
Project panel.

XMP Metadata
A major feature implemented
across several components of the
Adobe Creative Suite 4 product
line is support for XMP Metadata.
Although it will have little direct
impact on an individual motion
graphics artist (which is our focus),
some who manage and work in
larger facilities will be very happy
to see it. 

In broad terms, metadata
means additional information that
accompanies a file, such as when,
where, and how it was shot; copy-
right information; technical specs
(such as camera focal length); job
number or work ticket; et cetera.
XMP Metadata is accessible by
selecting a file and choosing
Window > Metadata. You can also
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After Effects CS4 now includes a button
at the bottom of the Project panel to
open the Interpret Footage dialog for 
a selected footage item.

XMP Metadata allows you track information about your assets through your entire
production and workflow.
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use scripting to access and manipulate metadata. Preference settings
for XMP Metadata reside at the bottom of the Media & Disk Cache 
preference pane.

An example of using metadata to save and re-import comp and layer
markers is included in the section on Chapter 41 later in this document.

Improved OpenEXR Support
After Effects CS4 now comes with the ProEXR plug-in set from fnord
software (available free for CS3 from www.fnordware.com/ProEXR/). This
offers enhanced support of the OpenEXR format commonly used by
high-end effects houses. ProEXR’s benefits include:

� Support for all the OpenEXR compression options, including B44
compression.

� Output as RGB or Luminance/Chroma channels.

� Retention of EXR color space information.

� Support for both 32-bit and 16-bit floating point.

� Full control over alpha channel processing.

The ProEXR package contains the EXtractoR and IDentifier plug-ins,
which allow access to the additional non-image channels in an
OpenEXR file – including Object and Material IDs. 

For more information, download the ProEXR PDF manual
(www.fnordware.com/ProEXR/ProEXR_Manual.pdf) and jump to the
ProEXR in After Effects section, which starts about halfway in.
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FLV and F4V Updates
After Effects CS4 has several updates in
the area of FLV and F4V web video
formats:

� Both FLV and F4V formats can now
be imported.

� After Effects can now render F4V
media in addition to the previously
supported FLV format. 

� You can now embed XMP Metadata
in FLV and F4V renders. This can be
found under the Options menu in the
FLV | F4V Export Settings dialog. 

� The Filters tab that previously existed in the FLV Export Settings dialog
has been removed – you will need to do any pre-processing such as
denoising in your final comp as opposed to inside the Output Module.

Also note that you no longer need to bring an FLV file into Flash to 
test it. Instead, download the Adobe Media Player. 

Hidden under the Options menu in
the FLV | F4V format options dialog
is the ability to add extensive 
XMP Metadata tags.
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37 Integration 101
One of the main initiatives behind Adobe Creative Suite 4 was improv-
ing the interoperability between Adobe applications. After Effects CS4
offers the following enhancements:

� Importing Adobe Photoshop CS4 Extended 3D layers (discussed in
the section on Chapter 14).

� The ability to convert Photoshop text to either solids with masks or to
shape layers (discussed in the section on Chapter 20).

� Exporting XFL projects to Adobe Flash Professional CS4.

� Creating After Effects compositions in Adobe Device Central CS4.

� Improved functionality with Adobe Premiere Pro CS4 and
Soundbooth CS4.

We’ll discuss those last three in more detail below.

Web Video
The big feature here is the ability to export an After Effects composition
as an XFL format project, which can then be opened by Adobe Flash CS4
Professional. These layers may then be trimmed, transformed, or have
interactivity added to them within Flash; you may also insert new 
symbols in-between these layers in Flash.

During export, each After Effects layer is usually rendered to its own
FLV movie or PNG sequence that is then used by Flash. Under certain
circumstances, your sources may be passed directly through to Flash,
along with any 2D transform properties (Scale, Position, Rotation,
Opacity) that were altered or keyframed in After Effects. Some of these
special circumstances include:

� The underlying footage must employ a format
natively used by Flash (such as a PNG or JPEG still
image, or an FLV movie or PNG sequence).

� No effects may be added to the layer. Likewise, the
layer cannot use a Blending Mode, may not be time
stretched, and cannot employ motion blur, frame
blending, 3D, or be matted or stenciled.

� The layer’s duration must not be trimmed. (Note
that if the source footage is longer than the composi-
tion, this counts as trimming!)

Let’s work our way through an example to get a
better idea of how this works.

Step 1: Open the comp [37.1-XFL Export]. It contains a modified ver-
sion of the Adobe Encore button project on page 593 of CMG4, with the
video thumbnails (GI_WaterElements.flv and GI_CyberTechnology.flv)
already compressed as FLV files. Also note that the background –
DV_InnerGaze_307019.jpg – is already in the Flash-friendly JPG format.
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Our goal is to export this animation
from After Effects into Flash.
Background courtesy Digital Vision;
video insets courtesy Getty Images.

Motion(less) Link
On page 595 in CMG4, we
mentioned a tip on how to
import an Apple Motion project
into After Effects. Unfortunately,
this no longer works with 
Motion (at least, as of Motion 3,
Mac OS 10.5 and QuickTime 7.5).
Indeed, the “rename as .mov” 
trick will cause After Effects CS3
or CS4 to crash the next time
you import a file, while the
“Enable All Files” trick returns an
error message.

G O T C H A
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Step 2: RAM Preview the comp to become familiar
with its animations. Select DV_InnerGaze_ 307019.jpg
and press U; notice that its Position parameter has
keyframes. Then select GI_Water Elements.flv and
press UU to reveal its animating property (Opacity)
as well as its other transform properties that have
been edited from their defaults (Position and Scale).
The layer GI_Cyber Technology.flv has the same
properties edited. Since these layers are already in
Flash-friendly formats, and have no other effects or
modes applied to them, these transform properties
will be preserved during the XFL export. 

Step 3: Select File > Export > Adobe Flash Pro fes -
sional (XFL). Enable the Rasterize option, and set the
Format popup to FLV. Then click on the Format
Options button, which will open the FLV | F4V Export
Settings dialog originally mentioned on page 592 of
CMG4. From the Preset menu choose the FLV – Same
As Source (Flash 8 and Higher) option. It is important
that you select one of the Flash 8 options, as these can
support alpha channels.

Click on the Video tab below, and under Basic
Video Settings enable Encode Alpha Channel. This
will preserve the alpha channels for your layers
(including the animating text layers with motion
blur), making it easier to combine them with other
content in Flash. We also tend to scroll down and set
Advanced Settings > Quality to Best (if you don’t see
the Quality menu, scroll down using the scroll bar on
the right side of the dialog). 

Step 4: Click OK, and then OK in the XFL dialog.
Choose where you want to save this project. Pay
attention to the Exporting dialog that appears next,
as well as the Video switch (the eyeball icon) for each
of the layers in the Timeline panel: These will indi-
cate which layer is currently being processed. You will
notice that After Effects will render most of the lay-
ers, but will skip over the FLV and JPG layers.

Step 5: After Effects will generate an HTML-format
report file and save it next to your XFL project. This
contains information on which layers were re-
 rendered (and why), as well as on which layers were
okay in their current state and are therefore merely
linked to. Double-click this HTML file to open it in
your web browser.
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Step 3: Make sure you enable Encode Alpha Channel for the
FLV content you are about to render.

Step 2: FLV and JPG files are supported formats and
therefore may be exported intact into Flash, even though
their transform properties are animating or otherwise
altered from their defaults.
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Step 6: If you have a copy of Flash
CS4 Professional, open the XFL pro-
ject file you saved above. The Scene
panel should resemble your Comp
panel in After Effects, with the main
difference being you will see the
entire background image – it will
not be cropped by the comp’s
boundaries. (If you want to crop any
layer, create a comp-sized solid and
use it as an alpha matte or stencil
for the layers below. Note that this
will cause all of the layers below to
be rendered upon export.)

Toggle the layers’ Show/Hide
switches (under the eyeball in the
Timeline) and scrub the time indi-
cator to confirm that these layers
and their animations came across
intact. Look closely, however, and
you will notice that one layer from
the After Effects composition is
missing: TU_Manzanita.mov. Unfortunately, audio
is not exported to XFL projects in CS4.

Step 7: Select GI_WaterElements.flv (a supported
layer) and click on the Motion Editor tab. Scroll
through its Basic motion, Transformation, and Color
Effect parameters: You will see it
retained its Scale and Position val-
ues along with its Opacity (Alpha
Amount) animation, meaning you
can resize and reposition them
inside Flash without re-rendering
or loss of quality. Unfortunately, a
keyframe has been created for
every frame of the animation.
Adobe does this to ensure accura-
cy, but it comes at the cost of
editability. 

Despite its obvious shortcom-
ings (lack of audio support and an
overabundance of keyframes), we
still feel this new feature goes a
long way toward aiding After
Effects artists who wish to create
content for the web.
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Step 6: The resulting Scene panel in
Flash will show a re-creation of your
After Effects comp.

Step 7: Simple transformations are
retained for supported layers. However,
keyframes are generated for every
frame of an animation.
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Mobile Media
Another large step forward in integration is the new workflow between
Adobe Device Central CS4 and After Effects CS4. Creating content for
mobile devices is an important new business opportunity. The problem
is, there are many different devices out there, each with its own specifi-
cations and requirements. This process has been greatly simplified by
the new ability to use Device Central to automatically build a chain of
After Effects compositions. Try it for yourself:

Step 1: Open Adobe Device Central. In the welcome screen that appears,
click on Create New Mobile > After Effects File.

Step 2: In the Device Sets panel in the upper left corner, click on the
New Device Set folder icon. Give your new folder a name such as “Cell
Phone Project” and press Return.

Step 3: Time to add some devices to your set. Let’s start by adding
some universal Flash Lite devices. In the Local Library panel, twirl open
Flash Lite and drag the first entry – Flash Lite 1.1 16 176×208 – into your
new folder (make sure you drag it into the folder, not below). The basic
technical characteristics of this device will appear in the main New
Composition panel at right.

Step 4: Add two more devices
from the Flash Lite library – such
as Flash Lite 2.1 16 240×320 and
Flash Lite 3.0 16 480×640 – to your
device set.

Step 5: If your computer has an
internet connection, turn your
attention to the Online Library
panel. It points to specific device
profiles that exists on Adobe’s
server. Add three more devices to
your Device Set (we added the
Motorola RAZR V3m, Nokia 3110,
and Sony Ericsson K630i). As you
drag them into your Device Set,
these profiles will be downloaded
and added to your Local Library.
Ignore the grayed-out devices for
now; their profiles are currently
unavailable.

Step 6: Select the Cell Phone
Project folder to see all of the
devices in your set in the New Composition panel at right. In some cases,
you will see a graphic of the actual phone.
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Step 6: All of the devices you add to
your Device Set will be visible in the
New Composition panel at right.

Step 2: Create a New Device Set folder
to hold the descriptions of the mobile
devices you will be targeting.
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Step 7: Enable the Create Master
Composition option at the top of the
New Composition panel – this is very
important! Then click the Create but-
ton in the lower right corner of this
panel. You will be returned to After
Effects, and a new folder named
Device Central Comps will be created
for you. (If you can’t find it, select the
QuickSearch dialog at the top of the
Project panel and search for “Device
Master”. Select this comp, then clear
the QuickSearch field.)

Step 8: Open the comp [Device
Master]. It will contain a black
(empty) stage with red bars down the
sides. The red bars indicate the area
that will be cropped by different cell
phones. Solo the guide layers in the
[Device Central] comp to see how
much each one will crop your univer-
sal master image; disable all the solo
switches when done.

Step 9: Drag a source file or comp –
such as [37.1-XFL Export] – into
[Device Master] and place it below all
of the nested guide comps. Scale it
down and position it to fit inside
[Device Master] so that it is nicely
framed, taking the red cropping bars
into account.

Step 10: Tap the Shift key to open the
Mini-Flowchart. You will see that a
number of “guide” comps – one per
device in your set – are nested into
[Device Master]. [Device Master]
then flows into one output comp per
device in your set.

Step 11: Tap Shift to open the Mini-
Flowchart again. Click on one of the
arrows exiting to the left out of any of
the device rendering comps (not the
guide comps). This will reveal that all
of the device comps also feed a mas-
ter Preview comp. Select [Preview];
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Step 9: Scale your source to neatly fit inside [Device Master],
taking the red cropping guides into account.

Step 10: [Device Master] is Grand Central Station in your mobile device project:
It contains nested guide layers that display each device’s cropping area, then
feeds comps to render for each individual device.
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Step 11: [Preview] displays all of your
device output comps side by side, so 
you can check their relative size and
cropping. This helps you make
adjustments to font sizes and layer
positions to ensure that your content
will look good on all of your requested
devices.

this displays the output of all of your device comps side by side to give
you an idea of how they look relative to each other – a pretty nifty trick!

The result of all this is saved in the folder 37.2-Device Central inside
CMG4CS4.aep. The only thing missing is rendering your individual
device comps. Check the video format required by each (detailed in
Device Central), and adjust their lengths to match your source. 

Adobe Premiere Pro
When clips are copied and pasted between Adobe Premiere Pro CS4 and
After Effects CS4, Premiere Pro’s time remapping is now converted to
After Effects’ time remapping (the two are based on different time
scales). Many blending modes are supported now as well. The same is
now true when After Effects imports a Premiere Pro project.

Dynamic Link
Dynamic Link – the ability to directly link select components of project
files from one Adobe video application into another without first having
to render an intermediate file – has undergone further evolution in
Creative Suite 4. Two additions include:

� Adobe Premiere Pro can now act as a Dynamic Link server, running in
the background and sending content to After Effects.

� Adobe Soundbooth can dynamically link to After Effects compositions.

Scaled Playback
A mobile device’s screen size
does not always equal its
recommended video size. 
For example, most devices 
with a 640x480 screen will take
only 320x240 video, which is
then scaled up by the device
during playback.

FA C T O I D



© Creating Motion Graphics � 4th Edition

38 Integration with 3D Applications
There is no change in After Effects CS4 regarding how it interfaces with
dedicated 3D applications. However, it should be noted that Photoshop
is becoming a 3D application in its own right: See the sidebar on
Vanishing Point Exchange on pages 254–255 in CMG4, and the demon-
stration of the new Photoshop Live 3D layers in the Chapter 14 section
earlier in this bonus chapter.

38B 3D Channel Effects
(Bonus Chapter PDF on DVD)

As noted earlier in this bonus chapter, all of the 3D Channel effects have
been updated to support 32-bit floating point color values. 

Additionally, CS4 contains the fnord ProEXR EXtractoR and IDentifier
plug-ins, which allow access to the additional non-image channels in
an OpenEXR file – including Object and Material IDs – in the floating
point format. (For more information on ProEXR, download the manual:
www.fnordware.com/ProEXR/ProEXR_Manual.pdf.)

39 Video Issues
There are two changes of note in After Effects CS4:

Center Cut Safe Areas
Quite often, widescreen content with
an image aspect ratio of 16:9 (such as
high definition video) is converted to
an image aspect ratio of 4:3 (the old
television standard) by merely chop-
ping off the left and right sides. This
process is known as “center cut.”

When you create a widescreen
comp in After Effects CS4 and enable
the viewing of Safe Areas (toggle by
pressing the ′ key), the safe areas for 
a 4:3 center cut image are displayed
in addition to the safe areas for the
overall 16:9 image. To be safe, make
sure your text, station ID bugs, and other important elements reside
inside these areas. The placement of these additional guides may be
adjusted in Preferences > Grids & Guides.

New Pixel Aspect Ratios
A dirty little secret that has existed for ages is that most desktop video
applications have been using slightly wrong pixel aspect ratios when
working with standard definition footage. The difference is almost
imperceptible to the human eye, but some engineering departments of

43

Bonus Chapter: After Effects CS4 //

After Effects CS4 helpfully displays 
4:3 center cut safe areas in 
16:9 widescreen comps.
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some networks actually care about such things. So as of Creative Suite 4,
the following pixel aspect ratios have been corrected across the Adobe
product line:

format old (incorrect) new (correct)
4:3 NTSC 0.90 (9/10) ~0.91 (10/11)
16:9 NTSC 1.20 (6/5) ~1.21 (40/33)
4:3 PAL 1.07 (16/15) ~1.09 (59/54)
16:9 PAL 1.42 (64/45) ~1.46 (118/81)

The cause behind the math errors in previous versions was the differ-
ence between Production Aperture (the entire frame) and Clean Aperture
(the portion of the frame that is supposed to be available for viewing).
For example, a 720 pixel wide frame contains extra pixels that were not
supposed to taken into account (4 pixels on the left and right of an NTSC
4:3 frame). The new ratios are based on the slightly smaller, more correct
Clean Aperture sizes.

As a result of this new math, After Effects uses slightly different sizes
for square pixel compositions, such as 720×534 for NTSC D1. A side
effect of this is that some older content – such as 720×540 pixel still
images and renders – will no longer exactly fit into its corresponding
nonsquare-pixel comp in After Effects CS4. For example, in this partic-
ular case you will either need to trim a little extra off the top and bottom,
or allow for some blank space on the left and right. You can experiment
with this in the D1 NTSC comp [39.2-PAR Changes].

Old projects opened into After Effects are automatically converted to
use the new PARs. This is driving some users crazy, and can cause errors
when combining material generated in After Effects CS4 with material
generated in older versions or other programs. However, for the daring,
there is an undocumented and unsupported fix. We suggest this only as
a temporary workaround until you become more comfortable with the
new, correct PARs:

� Quit After Effects.

� Open the Text Preferences file (described on page 671 of CMG4); the
name will now reflect version 9.0 rather than 8.0. For example, the path
on Mac is username > Library > Preferences > Adobe > After Effects >
9.0 > Adobe After Effects 9.0 Prefs; the path is similar under Windows.

� Search for the line “Disable Automatic Upgrade of PAR” and change
the number that appears afterward from “0” to “1”. Save.

� Restart After Effects.

Now when you open an old project (one that has not been saved yet
by After Effects CS4), it will use the pre-CS4 values. Note that any new
comps you create, or footage you import, will get the new ratios.

To convert your old project to the new values after this change, a new
menu item will appear: File > Upgrade Pixel Aspect Ratios. Select it, and
After Effects will comb through your comps and footage items, updating
them to use the new values, then report how many items were upgraded.
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Production versus 
Clean Aperture
For a more thorough technical
explanation of Production
versus Clean Aperture, use 
this link to jump straight to 
the subject in Chris Pirazzi’s
classic article Programmer’s
Guide to Video Systems:
www.lurkertech.com/lg/
video-systems/#rp187.

FA C T O I D



Other tweaks and enhancements include:

� There are now three dedicated action buttons:
Stop, Pause/Continue, and Render. Previously
there was just a Render button; when you clicked
Render, it would turn into Stop while a second
Pause/Continue appeared above it. This caused
some confusion, leading some users to acciden-
tally Stop a render when they intended to Pause
then Continue it. 

� If your disk runs out of space in the middle of a
render, After Effects will now pause rather than
stop the render. This gives you a chance to free up
some disk space and then continue a render, writ-
ing to the same file as when you started.

� There are now buttons in the Render Queue to
directly add or delete Output Modules (previous-
ly, adding an Output Module required a trip to the
menu item Composition > Add Output Module).

� You can drag an Output Module to the Project
panel (make sure you drag just the Output
Module, not the entire item in the Render Queue!).
If you have already rendered this comp, the result-
ing movie or image will be added to the project. If
you have not rendered this item yet, a placehold-
er will be created; the placeholder will be automat-
ically replaced with the actual file after rendering.
Either the placeholder or the file can be used as a
layer in another composition, allowing you to set
up chains where one comp uses the output of
another comp that has not yet been rendered.
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40 Rendering Queue
The Render Queue panel has been rearranged in After Effects CS4 with
a priority of saving space. This allows you to see more comps in the
queue when it is docked into a restricted space such as the Timeline
panel’s frame.
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The new Render Queue panel is considerably
more compact and space-efficient.

To add an Output Module to an already
queued render, click on the + button next
to the existing Output Module.

An Output Module can be dragged to the Project panel
to create either a Placeholder (shown here) or a copy of
the rendered output. Note that the placeholder may
have the wrong frame rate and duration (this item
actually has a rate of 29.97 fps and a duration of 02:00)
until the source comp is rendered.



41 Advanced Rendering
The settings for multiprocessor rendering are more intuitive in After
Effects CS4. Also, this chapter is a good place to show off some of the
capabilities of XMP Metadata (first mentioned back in the section on
Chapter 36).

Multiprocessing
Preferences > Memory &
Multiprocessing consolidates
what used to be components
of two preference panes in
CS3 (Memory & Cache and
Multiprocessing). This uni-
fied preference pane pulls off
the rare trick of being more
powerful while also being
easier to understand. It is a
good idea to allocate
between 1 and 2 GB per CPU,
and to leave a CPU free for
other applications (assuming
you’re the type who likes to
web surf while rendering in
the background).

XMP Metadata for Markers
Although support for XMP Metadata will be most appealing to those
who work on larger projects or in larger facilities, there are still cases
where it can be useful to the normal motion graphics artist. For exam-
ple, After Effects CS4 can remember all of the markers in a composition
and store those with a rendered movie of that comp. Import the ren-
dered movie, and you get all of the original markers as well. (Note that
the following exercise requires 9.0.1 to work smoothly; there were some
issues in 9.0.0.)

Step 1: Open Preferences > Media & Disk Cache, and enable Create
Layer Markers from Footage XMP Metadata.

Step 2: Open the comp [41.1-XMP Markers]. Several of the layers have
markers (with durations – see the section on Chapter 6).
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Step 2: The source comp has markers
with duration on several of the layers.

The new consolidated Memory &
Multiprocessing preference is much
easier to set up and understand.



42 Prerendering and Proxies
No changes in CS4, aside from the ability to drag
an unrendered Output Module to the Project
panel to create a Placeholder (see section on
Chapter 40).

43 What’s Your Preference?
The most obvious change is that the Preferences
dialog was redesigned in CS4 (right). The popup
menu previously used to access different prefer-
ence panes has been replaced with a list of but-
tons down the left side. Additionally, the order
of the panes has been slightly rearranged, and
the contents of a few of the panes have been
updated. On the next page, we will briefly dis-
cuss the changes to each pane affected; most of
these subjects have already been discussed ear-
lier in this bonus chapter in the context of their
actual features.
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Step 3: Type Command+M (Control+M) to add
this comp to the Render Queue; choose a place
to save the rendered file.

Step 4: Open the Output
Module settings for this comp.
At the top of this dialog, make
sure that Include Source XMP
Metadata is enabled and that
the Post-Render Action popup
is set to Import. Close the
Output Module settings and render the movie.

Step 5: After rendering, the resulting movie will
appear in the Project panel. Drag it to the Create
a New Composition button at the bottom of the
Project panel. The layer generated from your
rendered movie will have all of the layer markers
you saw in [41.1-XMP Markers].
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Step 5: The rendered movie retains all
of the markers that appeared in the
original comp.

Step 4: Enable Include Source XMP
Metadata to save your metadata with
your rendered movie. (Also remember 
to enable the marker preference back 
in Step 1!)
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Previews
As mentioned in the section on Chapter 2, OpenGL now as an Adaptive
Resolution option.

Display
The Auto-zoom When Resolution Changes preference has been replaced
by an Auto option for the Resolution popup along the bottom of the
Comp panel (see Chapter 2).

Grids & Guides
Hand in hand with the addition of the “center cut” safe area display (see
Chapter 39), you can set where these additional safe margin grids are
drawn.

Label Defaults
As mentioned in Chapter 21, Adjustment Layers now have their own
label color.

Memory & Cache
The Memory portion of this pane has been moved to the expanded
Memory & Multiprocessing pane (see Chapter 41). The old pane has
been renamed Media & Disk Cache, and has taken on the new XMP
Metadata options (see the relevant comments in the section on Chapters
36 and 41).

While we’re here, an option that existed in CS3 could stand some clar-
ification: The Clean Database & Cache button does not actually erase
any data; it just removes unused links to that data. You will need to man-
ually delete no-longer-needed items from the Cache folder in order to
recover the disk space consumed by these.

User Interface Colors
This preference pane has been renamed Appearance. The Brightness
range is also now larger.

Multiprocessing
This pane has been expanded to cover Memory & Multiprocessing, and
has much clearer options (see Chapter 41).

Very special thanks to Todd Kopriva (After Effects documentation lead),
who was a tremendous aid in fleshing out the features mentioned in this
bonus chapter. Todd’s excellent After Effects blog can be found at
blogs.adobe.com/toddkopriva/. Thanks also to Peter Constable who
steered us through understanding the new scene-referred color profile
behavior. 
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