
There are several ways to create 3D content for After Effects,
including native 3D layers, 3D renders, and 3D effects.

Unfortunately, not all of these are compatible with each other,
resulting in problems – such as one “3D” layer not casting
shadows onto or intersecting with another “3D” layer. Add
that to the usual issues with combining 2D and 3D layers in
the same composition, and it’s no wonder some users are left
confounded and confused.

In this chapter, we’ll explain the issues with creating and using differ-
ent 3D content, as well as how to overcome some of the resulting prob-
lems. Then we’ll move onto creating 3D content with Adobe Photoshop
Extended (including Vanishing Point Exchange, 3D model import, and
the new Adobe Repoussé extrusion engine) as well as the newly bun-
dled Digieffects FreeForm 3D warping and displacement effect. We’ll
end with a brief summary of useful third-party 3D plug-ins.
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Combining 3D layers
from different sources.

Example Project
Explore the 16-Example
Project.aep file as you read this
chapter; references to [Ex.##]
refer to specific compositions
within the project file. 

As some 3D effects are slow to
preview, we suggest enabling
Preferences > Memory &
Multiprocessing > Render
Multiple Frames Simultaneously.

Parallel Worlds

16

2D and 3D layers may
peacefully coexist in
the same comp. A
benefit of this is that
2D layers – such as
the title, bug, and
background – stay in
the same place as the
3D camera moves
around the 3D layers.

Excerpt from Creating Motion Graphics with After Effects, 5th Edition for CS5.
Copyright © 2010 Trish and Chris Meyer.

Published by Focal Press, ISBN: 978-0-240-81415-5

No part of this publication may be reproduced or distributed in any form or by any means.



2D versus 3D Layers
Interactions between 2D and 3D layers were discussed at the end of
Chapter 13, but the subject is worth recapping here, as it provides the
foundation for almost everything else we’ll be discussing in this chapter.

Layers in After Effects normally exist in 2D
space and are composited together to create a
final 2D image. Enabling a layer’s 3D Layer switch
has two consequences: It allows the layer to be
moved in three dimensions, but it also routes that
layer off to a separate internal rendering engine.
The output of that separate rendering engine is a
2D layer, which is then composited with the other
2D layers inside a composition. This is how 2D and
3D layers can coexist inside the same comp: 3D
layers must eventually be converted to 2D layers.

When multiple 3D layers are adjacent to each
other in the Timeline panel’s layer stack, they may
interact by way of intersecting each other, casting
shadows onto each other, and receiving shadows
from each other. However, if a 2D layer appears
between a selection of 3D layers, the 2D layer acts
as a “rendering break” that separates adjacent 3D
layers into their own groups. Although all 3D lay-
ers in a comp react to the same 3D lights and cam-
eras in a comp, a particular 3D layer may interact
only with adjacent 3D layers inside its group. Try
this with [Ex.01_2D+3D Layers] in this chapter’s
example project: Drag one of the 2D layers (2D
Title or 2D Bug) between the 3D layers (the pin-
wheel and bikewheel layers) and observe how the
shadow patterns change.

Why is this happening? 3D layers cannot cast
“3D” shadows (those created by 3D lights) onto 2D
layers – again, you will notice in [Ex.01] that the
full-frame background video does not receive shadows from any of the
3D layers. A consequence of this is that if a group of 3D layers is col-
lapsed internally into a 2D layer during compositing, a 3D layer in
another group cannot cast 3D shadows onto this collapsed group, and
vice versa. That’s why some of the shadow patterns between 3D objects in
[Ex.01] appear to toggle off and on as you drag 2D layers between them.

However, you can still use normal 2D compositing tricks. For exam-
ple, a 2D shadow created using Effects or Layer Styles will “fall” from a
2D layer onto the 3D layer group underneath as well as other 2D layers
(we used this trick in [Ex.01] for the title and bug); a blending mode set
for a 3D layer will interact with both 2D and 3D layers underneath (try
it with one of the 3D layers in [Ex.01]).
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Placing a 2D layer between 3D layers in the Timeline panel
(above) acts as a “rendering break” which disrupts how
shadows fall between them (below). Note the lack of shadows
on the front bikewheel.



A project created in Maxon CINEMA 4D
may be able to pass its camera and
lights onto After Effects, but the 3D
render will be a 2D layer (above). 
This means it will not accept shadows
created by 3D layers added in After
Effects (right). Fortunately, you’re about
to learn a trick to make those shadows
work again. Wall texture courtesy 
Digital Vision/Naked & Scared.

Different Types of 3D Layers
Now that we have a handle on how 2D and 3D layers interact (or don’t,
in some cases), next comes understanding what is really a 3D layer, and
what is really a 2D layer. There are a surprising number of ways to cre-
ate 3D imagery that require 2D layers in After Effects. First we’ll survey
the different ways of creating 3D imagery, then demonstrate how to
overcome some of the resulting limitations.

After Effects 3D Layers: If a layer has its 3D Layer switch enabled, it’s a
true 3D layer as far as After Effects is concerned. This includes any
footage item you drag into a composition, as well as text layers, shape
layers, and solids that you create inside a composition – as long as you
enable their 3D Layer switches. The same applies to nested composi-
tions: Interesting and useful things happen if you have a nested compo-
sition containing 3D layers, then enable both the 3D Layer and Collapse
Transformations switches for that nested comp. All of the 3D geometry
comes forward into the current comp, but you have only one layer to
manage. This is discussed in more detail in Chapter 20, and is demon-
strated in comp [Ex.02a].

Per-Character 3D Text: Normally, text layers are rendered as 2D layers.
If you enable the 3D Layer switch for a text layer, all of the text is manip-
ulated in 3D as one flat plane. However, if you select the Animate >
Enable Per-character 3D option for a Text layer, each individual charac-
ter will be treated as a separate 3D layer, including the ability for char-
acters in the same text layer to cast shadows onto each other. This is
discussed in more detail in Chapter 21 and demonstrated here in comps
[Ex.02b] and [Ex.02c]. The catch: If you apply any effect or layer style to
a Per-Character 3D Text layer, it breaks the 3D interactions. Try applying

Effect > Perspective > Bevel Alpha to the text layer in
either [Ex.02b] or [Ex.02c] and note that the shadow
interaction is lost. 

Renders from a 3D Program: When you create a scene in
a dedicated 3D program, it has its own camera and lights
that are taken into account when the scene is rendered.
Explore the various layers in comp [Ex.02d_starter]: The
3D-rendered room (layer 3) was imported into After

Effects along with its camera and
lights. As 3D perspective is already
factored into the render, this layer
must be treated as a 2D layer – you
don’t want the layer reacting to
both the 3D program’s camera as
well as the After Effects camera.
This creates issues when you want
to insert additional 3D elements in
After Effects: The wall texture 3D
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A benefit of Per-Character 3D text is 
that shadows may be cast between
characters in the same text layer as well
as onto adjacent 3D layers. Be warned
that applying an effect to the text layer
will disable its shadows. Background
courtesy Digital Vision/Prototype.



layer added in After Effects catches shadows from the After Effects 3D
text layer (notice they are adjacent layers so they are rendered as a
group). However, the 3D-rendered room does not receive these shad-
ows because it’s a 2D layer. Chapter 40 on 3D Integration is dedicated to
dealing with these issues; later in this chapter we will show how to cast
shadows from 3D layers in After Effects onto other 2D layers (as employed
in comp [Ex.02d-final]).

Layers with 3D Effects Applied: Many effects – from such classics as
Shatter and CC Cylinder, to the newly bundled Digieffects FreeForm, to
popular third-party effects such as Zaxwerks Invigorator,
Trapcode Particular, and Boris BCC Extruded Text – create
3D imagery with depth and perspective. Most “3D” effects
also have options to react to 3D camera and lights in After
Effects. However, in reality these effects are miniature 3D
programs residing inside After Effects: Rather than using
the After Effects rendering engine, they have their own
internal rendering engines that create their own imagery.
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3D effects such as Shatter are normally
applied to 2D layers (above). As a result,
they do not cast nor receive 3D shadows
(A); they also serve as render breaks to
stop other 3D layers from rendering as a
group. However, we’ll show you a trick to
regain some 3D interaction (B). Footage
courtesy Getty Images/Discovery.

The result is a 2D layer – just like one produced by a dedicated 3D pro-
gram – that does not interact with 3D layers in After Effects, as demon-
strated in [Ex.02e_starter]. However, there is a trick you can employ that
allows you to enable that 3D Layer switch and regain some interaction.
This is shown in comp [Ex.02e-final] and will be demonstrated later in
this chapter.

3D Imagery Imported from Photoshop Extended: Photoshop has been
gaining 3D capabilities over time. Currently, it can create two types of 3D
imagery which may then be imported into After Effects: Vanishing Point
Exchange and Live Photoshop 3D. Vanishing Point Exchange files con-
tain an arrangement of flat images with their 3D Layer switches enabled
in After Effects. Live Photoshop 3D (also used by Adobe Repoussé) is like
any other 3D effect mentioned above: The effect is doing the rendering,
and the result is a 2D layer. Later in this chapter, we will work through
exercises demonstrating these two ways of creating 3D imagery in
Photoshop Extended, including how to bring the result into After Effects.

To summarize: A surprising amount of 3D imagery, including that cre-
ated by 3D effects, actually involve 2D layers. 3D layers do not cast 3D
shadows onto 2D layers; 2D layers do not cast 3D shadows onto 3D layers.
But it is possible to work around some of these limitations.

Any still image with an outline or alpha
channel can be inflated by Repoussé
into a 3D model, as in [Ex.02f].
(In Photoshop CS5, open any file in
SOURCES > Objects, choose Select >
Load Selection, then click OK. Now apply
3D > Repoussé > Current Selection and
have fun!) Fish courtesy Getty Images.

A B



3D Shadows onto 2D Layers
There are many occasions where you may want 3D layers to cast 3D
shadows onto 2D layers. For example, you may want 3D layers added in
After Effects to cast shadows on a render from a dedicated 3D program.
Or you may have a full-frame 2D background layer that you want your
3D layers to cast shadows onto.

There is more than one solution to this puzzle. After years of trying dif-
ferent approaches, we’ve settled on what we call the “shadow catcher”
technique. With this approach, you place a white solid with its 3D Layer
switch enabled at the location in 3D space where the 2D layers should
be – this is what gives the shadows the correct size and perspective. You
then adjust the Material Options for this layer so that it receives shadows
but no other lighting effects, yielding pure shadows on a white back-
ground. Finally, you set the Blending Mode for this layer to Multiply so
the shadows on this layer are blended onto the 2D layer(s) underneath.
Let’s walk through an example:

Step 1: Open [Ex.03_starter] and RAM Preview: The composition con-
tains a set of 3D layers (the bike wheels and text) with an animated 3D
camera move. The 3D layers are set to cast and receive shadows; you will
see shadows falling from the forward wheels onto those behind. We’ve
also created a background out of two pieces of full-frame 2D stock
footage. We suspect this design might look better if all the elements
appeared as if they were in the same room.

Step 2: Add a Layer > New > Solid. Change its name to “Shadow
Catcher” and set its Color to white. Click OK. 

Step 3: Drag Shadow Catcher down the layer stack to be just above the
first 2D background layer (AB_DigitalBiz.mov) and enable its 3D Layer
switch (if the Switches column is not visible, press F4 to toggle it for-
ward). It will react to the 3D light in the scene and pop in front of most
of the 3D elements.

Step 4: Move to the end of the comp to view the elements in their “at
rest” position. Press P then Shift+S to reveal Shadow Catcher’s Position
and Scale. Increase its Z Position value until it moves behind all the
wheels, and adjust until the size of the shadow feels right for your virtu-
al room. As you do so, the layer will appear smaller as it recedes into the
distance; increase its Scale value as needed until the entire frame is filled
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Steps 3–4: Enable the 3D Layer switch
for the Shadow Catcher layer; it will
react to the light (A). Increase its Z
Position to place it behind the text 
and wheels (B). Increase its Scale as
necessary to fill the frame (C).

Step 1: The initial composition lacks
something. The wheels are casting
shadows onto each other, but the
foreground elements aren’t interacting
with the background elements. Grid
pattern courtesy Artbeats/Digital Biz.

A B C



again. (It’s okay to scale shadow catcher layers beyond 100% – the layer’s
scale does not affect the resolution of the shadow it catches.)

Step 5: Press Home to return to the start of the composition. As the
camera moves, Shadow Catcher might no longer fill the frame. Increase
its Scale value until it does. To be safe, scrub the current time indicator
to make sure Shadow Catcher covers the frame during the entire comp.
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BA C

Steps 6–7: Set Shadow Catcher so that
it no longer accepts lights and uses the
Multiply blending mode.

Casting shadows from the 3D layers
onto the 2D background helps unify the
scene (A). You can reduce the Opacity of
the shadow catching layer to tone down
the shadows (B), or even use a different
blending mode such as Color Burn (C).

onto the 2D background (try it with layer 4, the most prominent bike
wheel). And as with ordinary 3D shadows, you can increase the light’s
Shadow Diffusion to soften the shadows, or increase Composition >
Composition Settings > Advanced > Rendering Plug-in > Options >
Shadow Map Resolution to sharpen the shadows.

You can create more complex shadow catcher arrangements to cast
more complex shadows. For example, [Ex.06] in Chapter 40 demonstrates
how to correctly catch shadows on multiple surfaces in a 3D render. 

Step 6: Type AA to reveal Shadow Catcher’s
Material Options. By default, Accepts Shadows
is On, which is what we want. However, we
don’t want to pick up any shading falloff from
the light – so set Accepts Lights to Off. The
Shadow Catcher should now be evenly lit,
except for the shadows.

Step 7: Press F4 to reveal the Modes panel.
Set the blending mode for the Shadow Catcher
layer to Multiply. The shadows will now
appear on your 2D background composite!
RAM Preview to verify that these new shadows
react to the animating camera position and
text layer.

There are a few ways to further tweak the
result. With Shadow Catcher still selected,
press T to reveal its Opacity; lower this value to
reduce the strength of the shadows on the 2D
background. Try a different blending mode
such as Color Burn to create a more stylized
look. Increasing the Light Transmission para-
meter will cause the 3D layers to be projected



Adobe Repoussé
In Creative Suite 5, Adobe built on the concept of
Live Photoshop 3D integration by adding Repoussé –
a powerful extrusion and beveling tool – to
Photoshop CS5 Extended. Layered Photoshop PSD
files created with Repoussé can be imported into
After Effects and animated in 3D (with similar limita-
tions as other Live 3D layers). Repoussé is explained
in detail in Photoshop’s Help file; here is a quick tour:

In Photoshop CS5 Extended:

Step 1: Open file 16-Parallel Worlds > 16_Chapter
Sources > Repousse Text.psd. It contains a simple
line of text created in Photoshop. 

Step 2: Choose 3D > Repoussé > Text Layer. Photo shop
will tell you it has to rasterize the text; click Yes. The
Repoussé dialog box will open, and the text will be
extruded in 3D. Click and drag the text downward
slightly so you can better see the depth of the extrusion.

Step 3: First focus on the Extrude section. Experi -
ment with Depth, Scale, Twist, and the Shear/Bend
section. Depending on your video card, it can take
Repoussé some time to calculate the results. Once
you have a feel for how these parameters work, click
on the Extrude preset in the upper left corner of the
Repoussé Shape Presets, and reduce Extrude > Depth
to a more discreet value between 0.2 and 0.5.

Step 4: Next, play with the Inflate settings. A good
starting point is Angle = 90. Negative values cause the
faces of your object to be hollowed out. Strength
affects how the inflation is pulled out (or in), and is
very sensitive – values well under 1.0 can introduce
rendering anomalies with detailed selections.
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Step 3: In addition to adding extrusion depth,
the Extrude section (below) also allows you to
scale, twist, and shear the extrusion (above).

Step 5: Reset Inflate > Angle to 0 for now, and have fun with the
Bevel section. Setting Height and Width to 10 is a good starting
point for this file; negative Height values cut into the face. The
Contour popup gives you several different shapes to work with;
the more detailed shapes work better on simpler sources with
space between the outlines. Also beware of setting Width too high;
thinner portions of the letters will overlap and cause artifacts.

Step 6: The Scene Settings are worth exploring. Under the
Render Settings popup are several interesting choices, such as
Wireframe and Shaded Illustration (return to Default when you’re
done exploring). Lights contains several default arrangements;
Dawn works well with this example.



Step 7: Click OK to exit the Repoussé dialog. Make sure
Window > 3D is open, and select Scene (it’s at the top). In the
Render Settings at the bottom, set Quality to Ray Traced Draft:
The text will now render antialiased, with refined lighting
effects like shadows. In the 3D window, you can again edit the
materials applied to your object as well as the lighting. Note
that you will not be able to alter the lighting in After Effects.

Step 8: Choose File > Save As; make sure that the Format
popup in the Save dialog is set to Photoshop and that Layers
is enabled. Rename your file “My Repousse Model.psd” and
click Save. If a Photoshop Format Options dialog opens after
clicking Save, enable Maximize Compatibility and click OK.

In After Effects:

Step 9: Back in After Effects CS5 and the project file 16_Example
Project.aep, select the Ex.07 Adobe Repousse folder in the Project panel.
Then choose File > Import > File and select the PSD file you saved above
(our version is saved as 16_Chapter Sources > Repousse Model.psd).
After clicking Open, a second dialog will appear. Make sure that the
Import Kind popup is set to Composition – Retain Layer Sizes, and that
the Live Photoshop 3D option is enabled. Then click OK. Two items will
be created in the Project panel: a folder and a composition, both named
after your file. 

Step 10: Double-click the import-
ed composition to open it (or our
version [Ex.07_starter]). The layer
arrange ment is similar to the pre-
vious Live Photoshop 3D example,
with a camera, controller, and layer
with the Photoshop 3D effect applied. Press C to select the Camera tools
and move around the text to verify it’s not just another postcard in space. 

Toggle the Quality switch for layer 3 (the one with the Live Photoshop
3D effect) to Best. The text will now be ray-traced, but the scene will also
be a lot less responsive. Return Quality to Draft while you’re posing and
animating your scene, then make sure that the Render Settings popup
for Quality is set to Best when you render (Chapter 42).

To edit a Repoussé layer, select the layer with the
Live Photoshop 3D effect applied, choose Edit > Edit
Original to return to Photoshop, then choose 3D >
Repoussé > Edit in Repoussé. Save your file when
done, and return to After Effects – the layer will
update automatically.
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Importing a Repoussé file as a
composition results in three layers in
After Effects (below). Toggle the Quality
switch to Best for the layer with Live
Photoshop 3D applied to see the 
ray-traced render (above).

Steps 4–6: The Bevel section (above)
creates the classic “beveled text” look;
the Inflate section adds rounding to
the faces (top left). The Scene Settings
provide options for lighting and render
styles (top right).
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